how to start audio automatically on startup of audaity

I’m trying to use audacity to play an audio using the windows task scheduler. For this to work, audacity needs to start playing the audio automatically on startup, as does windows media player. The reason I want to use audacity is that it has the capability to play only one track of the stereo audio, which windows media player doesn’t. So far, I haven’t found a way to make audacity start playing automatically.
thanks, samw

I doubt it. Audacity doesn’t have very good remote access tools or command-line tools and the batch tools are just OK.

You can use Audacity to split up your stereo track into pieces and then make a new stereo track with just the work that you actually want. Would that help?

Koz

It’s a solution, but it means I have to rerecord all my scheduled tasks, then reschedule them. That’s a lot of work.
samw

There is Scripting but you have to compile Audacity to do that.

You could create an AutoHotkey script or executable to open the file then use the Audacity shortcuts to split the stereo track and solo/play then execute that script as a scheduled task: http://www.autohotkey.com/ .


Gale

SoX is a command line audio program that has excellent command line support: http://sox.sourceforge.net/

I’m using Audacity 2.0.3, on windows 7

The issue I was dealing with was how to play one track of a stereo audio through windows task scheduler, without reentering all the audio files back into windows task scheduler. This would have been a lot of work, since in some way unknown to me, someone had written an .xml file with a schedule for opening the audio files, and somehow put that into windows task scheduler.
Before finding the simple solution that follows, I was trying to find a media player that can play just one track of the stereo audios on start up, whch is also a simple solution, but I couldn’t find such a media player.
After consulting several computer programers, I found the simplest possible solution.
As they say, the simplest solution is the best. The one that I was lucky to find that works for this issue is to first re render the stereo audio files so that the audios are on only one track of the stereo files. I did this with Vegas pro, by setting the preferences to 5.1 surround sound; then placed the audio files on just one of the five tracks; then rendered the files to .wav
After that, I simply put the original file name on the new files, then switched out the original files, and inserted the new files. It worked.
What this seems to show is that Windows Task Scheduler doesn’t open a file according to what is inside the file, it simply opens files by file name. If a file with different content has the same file name, then it gets opened. I think this principle applies to any software program.

Thanks for the other suggestions, which I may find useful for other projects.
rw