How to remove skip between tracks

I am using Windows XP with current version of Audacity. When I playback my exported tracks from Audacity there is a skip between tracks. How do I remove the skip? The tracks are split tracks and the tracks change in the middle of songs. I want the tracks to play continuously with no skip between tracks.

MP3 files always have a short period of silence at the beginning. This is unavoidable for MP3 files as it is a limitation of the MP3 format.
To avoid having a bit of silence at the start of an exported track, do not export as MP3. If the exported files are for creating a CD, export in WAV format.
WMA files also have a bit of silence at the start. WAV, AIFF, FLAC and OGG files do not have this problem.

I ripped as wav using CDex and imported to Audacity as wav but I still get skips. After ripping it still had the skips. What format should I use to rip the original CD with no skips before importing into Audacity?

Are you talking only about ripping an entire CD as one file, or also about burning a CD with no skips between tracks?

Steve was talking about exporting a WAV (or WAV files) then using the WAV file(s) to burn a CD (instead of burning the CD from MP3 files).

If you want to rip the entire CD as one WAV using CDex, please see this http://manual.audacityteam.org/o/man/audio_cds.html#Windows .

If you are then trying to burn a gapless CD you want Disc at Once (DAO) mode set in the CD burner (if the burner supports it) and your best bet would be to export a single WAV then use a Cue Sheet to specify the track breaks. This should let the CD play continuously but you can still skip between tracks using next and previous.

This Tutorial may help http://manual.audacityteam.org/o/man/burning_music_files_to_a_cd.html#gapless .


Gale

I’m trying to get all the tracks in Audacity from CD (without skips) so I can edit. I was able to get it to work by importing as one wav file. However, when I burn to CD I want to be able to start on a certain track. Is there an easier way to do this without having to label the start/stop for each track? The idea thing would be to import each track individually without skips between tracks. Then I would do my edit and burn to CD.

Audacity does not import CD’s, so you are reliant on what the CD ripper does with a track that is really meant as part of a continuous whole. Are you suggesting that if you rip each track as WAV there is silence at the start and end of each WAV (when you import the WAV into Audacity and play it)?

You can try importing each track as a separate WAV then burning each WAV to CD with Disc at Once, but in my experience it is less likely to work then one WAV using a Cue Sheet. CDex can generate a Cue Sheet (look in the Tools menu).


Gale

I still got skips in Audacity importing as wav. When I tried ripping CD as Apple lossless or windows lossless then I didn’t get the skips when playing back with Windows Media player. However, I couldn’t get either the Apple lossless or the Windows lossless to import into Audacity for editing. It tells me ‘Audacity cannot open this type of file due to patent restrictions’. Is there a way around this or another lossless format I can try?

I think you’re flying further and further away from the airport.

When you used CDex to rip the CD, did it give you a pile of individual sound files? I used to use CDex, but it’s been a while. I don’t believe CDex retains the 2 second gap between songs, although I could be wrong. Are you seeing a 2 second hole between songs? Is that your objection?

What is the performance? Is it a symphony where you would notice a silent patch between the movements?

Koz

You are suggesting that the WAV for each ripped track has silence at the start and end of the WAV, and you don’t hear that silence if you rip the entire CD as one WAV? If so, are you sure you are not asking for silence to be inserted in the CDex settings? Which CDex version do you have?

Why not do as I suggested, import as one WAV, then use the Cue Sheet generated by CDex to burn from one edited WAV?

I don’t understand what the issue with CDex is, but FLAC is a lossless format you might be able to rip to with some rippers. Audacity as shipped imports FLAC.

Audacity does not support WMA lossless yet. You can use this WMA Lossless > WAV Command line encoder: http://www.microsoft.com/download/en/details.aspx?id=22391 .

Audacity should be able to import 16-bit Apple Lossless if you add FFmpeg to your computer. Audacity may not import 24-bit Apple Lossless.


Gale

I’ve been flying all around the airport for a week now trying to figure this out. It’s a split track choir cd where most of the tracks begin/end in middle of songs. You don’t hear the transition between tracks but you can start on a certain part of a song by using the track number.

I got a Windows debug issue error when I tried the CDex cue sheet.

Then try another version of CDex http://cdexos.sourceforge.net/?q=download . If you have the Beta, try the 1.51 release version. Or try some other ripping software.

Have you imported the Apple Lossless rip or the WMA Lossless (converted to WAV) into Audacity?

Really if you won’t say what you mean by a skip when you import a WAV ripped as a single track, we cannot help you with it. You’ve been asked three times now.

Are there skips or silences between the songs when you rip as a single WAV?

Is the problem that the CD burning software is finding the silence between the songs and creating a new track there, even though the track break is in the middle of the song? If so, turn the silence detection off in the CD burning software. Look in the help for that software.


Gale

sorry. By skip I mean hiccup. There is no silence just a little blip when it changes tracks. It is annoying because the tracks change in the middle of the song. Here is what finally worked. 1. I imported the CD using iTunes. (imported as apple lossless). 2. Imported the apple lossless file into Audacity and did my edit 3. exported from Audacity as a wav (Microsoft signed 16 bit PCM) 4. added wav file to iTunes playlist along with the other apple lossless tracks 5. In iTunes I used the burn playlist to disk (selected gap=None)

Thanks for everyone’s help with this! I have been pulling my hair out for a week. The missing piece was downloading the latest version of Audacity and downloading the ffmpeg for Audacity. This allowed me to import the apple lossless file into Audacity.

Thanks for confirming, If this was because you were cutting and pasting tracks together in Audacity, using Edit > Find Zero Crossings before the cut might help.

The other possibility is that CDex was not cutting the individual WAV files on CDDA frame boundaries, and this was upsetting iTunes when burning, but neither should be the case as far as I know.

Audacity can snap selections and cursor positions to CDDA frame boundaries if you put a checkmark in Snap To then right-click over a time box and choose a CDDA format, but CDDA boundaries may not match with zero crossing points. Selecting a zero crossing point for a join should be more important than CDDA boundaries these days.


Gale