How to remove clicking/popping

This is a recording of piano playing. The recording started out fine, but the clicking got worse over time, and then slowly went away. I didn’t touch the microphone or computer while I was recording, and I’d like to know what might have caused this. I use a CAD microphone, a MacBook Air with OSX 10.8.5, and Audacity 2.0.5.

I’ve tried the “Remove Clicking”, “Noise Removal”, and “Leveler” functions, but none of them helped, and sometimes made the clicking worse. Could anyone give me a suggestion?

Thank you so much!
Help.aiff (443 KB)

Your microphone and your Mac/Audacity are not syncing properly, I’m afraid. Removing this distortion is almost impossible. How long was your recording?

Have you checked if the microphone and everything else is running on the same settings? e.g. all on 44.1 KHz, 24 bit.

There’s an Apple utility in Programs/Utilities called “Audio/Midi setup”. Sometimes this needs to be configured too, even for a simple USB mic.

It usually is a good idea to split and save long sessions in shorter parts, if possible. If all settings are correct, you might have a hardware problem. USB3 interference, f.i. but that’s rare.

The first generation Air machines were underpowered with the idea of being wispy thin and totally portable. Recording live voice (or video) is not a wispy thin job. If the machine isn’t up to the job, you may get clicks and pops in the sound as the system struggles to keep up, worse if you have other programs working at the same time.

Upgrade to Audacity 2.1.0, close everything else and restart the machine. Set up for recording. Plug the microphone in before you start Audacity. See if that’s not better.

Generally, a show with holes in it like that is as good as it’s going to be.


The recording lasts for about an hour, but the clicking only is happening for 10 minutes of it (from 35 minutes to 45 minutes). Since most of it is okay, I think I got the settings right.

How do I check the settings of the microphone and my computer?

I plugged the microphone in before opening Audacity, then used System Preferences>Sound>Input to connect the microphone.

Thank you!

Try adjusting the “Audio to buffer” setting in “Edit > Preferences > Recording” (
The default is 100.
Until recently the default setting has been reliable on all platforms, but recently we’ve heard of problems on a few Mac computers where they require a smaller value than 100. This is surprising because the setting was created to allow old and underpowered machines to work by increasing the setting.

It seems to be something that Apple have changed fairly recently, and the effect is as you describe. Recording works ok for a while but then gradually starts to break up and crackle.

So should you try smaller or larger setting? I don’t know - could be either. You will need to make some test recordings with different settings. If smaller makes it worse, try larger, The default is 100, so if there is no improvement either way you can put it back to the default.

Thanks! I’ll try that.