How to hear headphone playback w/overdubbing ART usb mixer

Win 7 2.1.2 .exe

I did some searching [probably not enough], but am feeling a little brain-dead.
I’m just doing some simple multi track recording. Drums/guitar/vocals.

I am using an ART USB mix three channel mic/instrument/line mixer computer interface. Picture attached.

The only device that shows up appears to be USB audio CODEC.

Recording through this device is working fine. But I cannot hear any playback through my headphones using the monitor output on the mixer. This of course is essential to listen to the tracks when I overdubb.

Can anyone please help me with settings so that I can hear playback through my headphones using the monitor output on this ART usb mixer?

Thanks tons!

The mixer documentation never says the magic words “Zero Latency Monitoring,” But it left-handedly suggests that maybe if you don’t press the USB to CH2&CH3 button, the USB playback might appear in your headphones.

It might also appear in the show mix. It’s hard to know.

Audacity > Edit > Preferences > Recording: [X] Overdubbing… has to be the only thing selected.

If you select Playthrough, the computer’s headphone system will have your live performance on it, but it will be late with an echo.

One of the reviewer comments had some problems with that.

in the mixer manual. I’m a little foggy about what it’s doing.


Thanks Koz !!
I will work with that.

Yeah, this thing is not going to work. On to another interface…

I use a pure analog mixer, but a Behringer USB adapter certified for overdubbing. Plug the headphones into the UCA-202 and flip the little switch to Monitor. Also, see UCA-222 with the sporty red paint job and the UFO-202 with built-in phono preamp.

No, I don’t recommend Apple earbuds for production.

If the volume isn’t enough for you, plug the headphone socket into an entertainment or other amplified music system.