how to fix corrupted m4a file from iPhones Voice Memo App

Hi everybody
I’m new to the forum. I’m on Mac OS Mojave (10.14) and Audacity 2.3.0
My wife is a researcher and made two interviews using Voice Memo to record the sound. Unfortunately one of the two sound files doesn’t play. The first file works as it should. I can see that the corrupted file is the correct size (39mb - matches the working file in size).
My plan is to import the file into Audacity as raw data, but I don’t know how to get the correct import settings. So I tried to import the working file as raw data but still I don’t know how to get the settings (encoding, byte order, channels) right.

Playing the working file in VLC I get the following codec details:
mpeg aac audio (mp4a); stereo; 48000hz; 32 bits per sample.

Using Media Info I get the following info:
Complete name : /Users/kristianholtekofod/Desktop/“Marie” feb19.m4a
Format : MPEG-4
Format profile : Apple audio with iTunes info
Codec ID : M4A (M4A /mp42/isom)
File size : 29.3 MiB
Duration : 1h 1mn
Overall bit rate mode : Constant
Overall bit rate : 66.6 Kbps
Encoded date : UTC 2019-02-27 17:07:08
Tagged date : UTC 2019-02-27 17:07:10
Writing application : (iOS 12.1.4)
ID : 1
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 1h 1mn
Source duration : 1h 1mn
Bit rate mode : Constant
Bit rate : 64.0 Kbps
Channel(s) : 1 channel
Channel layout : C
Sampling rate : 48.0 KHz
Frame rate : 46.875 fps (1024 SPF)
Compression mode : Lossy
Stream size : 28.7 MiB (98%)
Source stream size : 28.7 MiB (98%)
Title : Core Media Audio
Encoded date : UTC 2019-02-27 17:07:08
Tagged date : UTC 2019-02-27 17:07:10

Using Audio File Health Check I get the following (on the corrupted file):
Audio File Health Check Version 1.6 (Build 87) 2019-03-02T21:31:44
2019-02-28T13:21:48 /Users/kristianholtekofod/Desktop/“Karin” feb 19.m4a
000000000000 Fatal: file is missing moov atom

So… can somebody figure out what settings I have to use to correctly importing the file as raw data?

using Voice Memo to record the sound.

On a what? Voice Memo is available on several different devices.

Unfortunately one of the two sound files doesn’t play.

Do we know what happened? Did the device run out of battery? Did the memory fill up?

file is missing moov atom

From fuzzy memory that’s the QuickTime or “Movie” format or header tag.

This could be messy. M4A support doesn’t come from Audacity. M4A comes from FFMpeg third party software. That and it’s a compressed format, so it’s not a simple matter of lining up the bits based on probability.

We need to wait for the higher power Apple elves.

It think it would go a long way if we figured out what caused the problem. The device trying valiantly to save the work in the face of a rapidly failing battery?


Was it the second interview?


Was it the second interview?

Never mind. You said so.


That won’t work.

“RAW data” import is for uncompressed “PCM” audio data.
“MP4” is compressed / encoded audio, so importing it as RAW data you will just get noise.

The short answer is, you can’t. MP4 has to be decoded by an MP4 decoder before there is any meaningful audio.

If the encoded audio data in the MP4 is corrupt, then there’s no chance of recovery - it’s gone forever.

If the encoded audio data is OK, and only the file header is damaged, then you “may” be able to recover the audio using VLC.
To do this:

  1. Make a copy of the MP4 file, and change the file name so that it ends with “.avi”
  2. In VLC go to: “Tools menu > Preferences > Input codecs”
  3. Set the option: “Damaged or incomplete AVI file” to “Always Fix”
  4. Now try playing the file in VLC.

If VLC is unable to repair / play the file, then that is probably the end of the story.

If VLC is able to play the file, then:
5) “Media menu > Convert / Save”, and convert the file to WAV format.

Whether this worked or not, you should change the “Damaged or incomplete AVI file” setting back to “Ask” when you have finished.

There are also some specialist MP4 repair applications and commercial services, but I’ve never had any success with any of them. Your mileage may vary.

1 Like

I know this is a blow, but you should go to great effort to find out what went wrong if you don’t already know. If you make a third recording, is it trash, too? My guess is that it won’t make a third recording.


Thanks for your answers.

Koz - The file was recorded on an iPhone 6s. The problem happened when the interview was finished. The screen had locked and when she unlocked the screen, the app had somehow frozen. Then she closed the app (swiped up) and when opening the app again the file was corrupted. Apparently this is how she usually does it, but usually the files are working fine when she reopens the app. Right now she is trying to make another recording to see how the app reacts this time.

Steve - I tried the VLC solution but I didn’t work. I saw a youtube video with someone who used a ‘hex editor’ and then a aac decoder/encoder. I managed to follow his steps with the hex editor but I couldn’t get the decoder to work. Do you think this could a possibility?

The method that I described with VLC is the only method that has ever worked for me. If it were me and the VLC method failed, I’d write it off.

The screen had locked and when she unlocked the screen, the app had somehow frozen.

You had two real-time supervisory processes fighting each other. The lock screen is security level, so it won.

I would have thought having a recording in progress would prevent the lock screen from activating. That’s how mine works. I have made very long recordings and The Screen/Battery Saver activated harmlessly—black screen, tap to resume—but not the lock screen.

Or did you just call it the wrong thing? Did it make you log in again?

The Screen Saver should not have affected anything.

I’d be digging in Settings. Also Google your brains out. “Corrupted Voice Memo,” etc.


Are you close to an Apple store or Genius Bar?


Yes theres an Apple store close by. Do you think they can help with file or is it to find out why the fault happened?

Steve’s approach worked for me - thank you so much :smiley: