How to export multiple tracks without all of them getting the same length?

I searched this forum and Google without any results. The only thing I could find was someone looking to find the opposite of what I’m trying to do…?

Anyway, here’s the problem and question:
Are use a recorder to make memos of different lengths and quality. I started using audacity so I can quickly compress EQ normalize multiple files etc.
I made a macro that can do this but I am finding that when exporting multiple files all of them get the same length as the audio with the longest time duration, which gives me excess silence…

Is there a way to change this behavior in audacity or is this the only way to export multiple files?

Macros will generally export the track as whatever length it is. Without knowing exactly what you are doing, I can’t guess at why that’s not happening for you.

That was real quick :smiley:

Ok here’s a step by step walkthrough:

  1. I open Audacity (version 2.30)
  2. I drag and drop multiple audio files into the “playlist” and let them load
  3. I press ctrl-A and select my custom macro (effects in order = >Stereo to Mono >Find Clipping >Compressor >Limiter >HPF >EQ >Normalize >Click Removal >Truncate Silence >END) and let it apply the effects.
  4. After letting the effects process i go to export and select “export multiple”, choose the same folder and overwrite existing files and then press export. And that’s it

The result being that all the files get the exact same length as the one with the longest duration :open_mouth:

Was this enough info?

I use windows 10 64bit

The current version of Audacity is 2.3.3. It is available (free) via the Audacity website:

I would strongly advise that you don’t directly overwrite the original files. If anything goes wrong, you could permanently lose the recordings. Much better to export to a new folder. If you don’t want your original, unprocessed files any more, you can delete them after you have checked that your modified versions are correct. This is a little more work, but a much safer workflow.

If you Export Multiple “based on Tracks”, then each track should export as the correct length. If that doesn’t happen, then it could be a bug in your old version of Audacity.

Thanks and great tips :smiley:

Where can i find this “based on tracks” option…??

Actually scratch the previous post!
I noticed that this only happens AFTER using my custom macro. The macro seems to fill in the silence… But i don’t know why or how to quickly remove it…? Any suggestions??

In the Export Multiple dialog:

What settings do you have in “Edit menu > Preferences > Quality”?

What settings do you have in “Edit menu > Preferences > Quality”?

SO I tested a copy of macro and each time after processing removing an effect from the chain starting at the end to the beginning…
Only after removed the Limiter it seemed that there was NO silence added to the end of the audio…

SO apparently there’s some kind of bug (or maybe it’s intentional?) that makes all the effects that come AFTER the compressor (limiter>hpf>eq etc) effect, add silence to match the longest audio…?


The Limiter effect is a “Nyquist” plug-in.
A limitation of Nyquist plug-ins is that when they process empty space in a track, they return silence where the empty space was, so if the selection is longer than the track, then the selected part of the track after the audio ends, will be replaced with silence.

I would have expected “Truncate Silence” to remove that added silence.
What format are the files that you are importing?

It’s not just the limiter that does this… It almost seems like it has more to do with doing CTRL A because when I only select one track it neatly leaves the end as is… :S

I’m using MP3 files :slight_smile:

Doh! My bad.
I forgot that Truncate Silence has a checkbox to “Truncate tracks independently”. Tick that box and try again.

Any feedback?

Have you tried my last suggestion?

…? Any tips…?
U haven’t responded to my previous msg

I have responded twice, so here it is for the third time:
In the “Truncate Silence” command, tick the checkbox: “Truncate tracks independently”

My internet was a bit jacked so apologies!

It’s working without any issues rn so thanks alot!! :smiley:

Good, so that has solved the mystery.

Are you aware that Macros can also be used for “batch processing”? That’s where you create a macro to act on one file, then run the macro on a batch of files, and Audacity “imports → processes → exports” each file in turn. This would be an alternative (and possibly “better”) way to tackle this kind of job.

haha yes…
I already wrote in my first msg that I’ve been using macros xD
BUT I’m starting to notice that the overal time of batch processing multiple files also significantly increases the time by about 3 to 4 times… :open_mouth:
So eventually doing it track by track is WAY faster :S