How to export audio with Silences?

Unfortunately Audacity does not have a built-in option for this, but there is an easy workaround.

For all tracks that start after time=0, select a section of the empty space, starting at time=0
(more about selecting audio here: Selecting Audio - Audacity Manual)

Then use “Generate menu > Silence” to generate silence into the selections

The tracks will now be exported from time=0 (because they start at time=0)

The workaround is to add silence (or a short bleep) to all the tracks …
Select all the tracks,(“Ctrl”+“A”), move the cursor to the start, (“J”), then generate, say 0.1 seconds of silence, or a short bleep.

You can also create one long silent track starting at 0 and export that plus the target track. Audacity will mix them at export.


That’s OK when exporting a single track, but not a solution when using “Export Multiple” based on tracks.

So is this a bug - or is it intentional “by design” ?


It’s “by design” (but not a good design).
I don’t think there is opposition to it being redesigned better :wink:

The export doesn’t match the timeline graphics or the timeline playback. That’s an unfortunate feature.


I like the single silent track approach because it lets me change my mind and move a track. If I do move with the other solutions, I have to remove the “fake silence,” and I can’t depend on UNDO. I can’t just shove left because Audacity will complain about “sound before zero.”


I seems to me that empty space before the audio should be treated as silence on export and mixing.

If the user has their audio starting at T=20 seconds with blank before it would seem to me that they want the audio to start at T-20 and not T=0

We could, of course, add a preference for this - but the default would have to be: Treat leading blank as silence = “on”

But personally I think a preference is overkill.

If a user has audio starting at T=20 and the want it to start at T=0, then they can easily shift it back with the Time-shift tool.

I do note that we have this longstanding ednote in the Manual on the Mixing page:
Gale 07Dec11: ToDo-2 There is no mention here or in Tracks Menu of how render handles white space before the audio begins or audio before zero. Should there be? Current behavior following r11248 is to preserve the clip length by no longer rendering white space between time zero and first audio as silence, and to preserve audio before time zero instead of discarding it. So people who want to export tracks with silent lead-ins preserved now have to generate silence after rendering. I think that tip at least should be in this page.

Users should not be forced into the kludgy solutions/workarounds given earlier in this thread to maintain the proper start times of their audio clips.

Oh and by the way empty space between sections of audio should also be treated as silence for export/mixing.

So do we need to log this on Bugzilla - or maybe write a short proposal - or is this a bit of “bad design” that we can just fix?


Thanks everyone for the tips, sorry for the late reply. The add silence worked just fine, don’t know why, since I only had to add a little silence, not fill in the entire “blank space”. But it worked! Thanks again.

Yes, it still works, but note that this topic began over 3 1/2 years ago. There’s a better solution in current versions of Audacity:
“Edit menu > Preferences > Import / Export => Ignore blank space at the beginning:”
See: Import / Export Preferences - Audacity Manual

Thanks, buy I’m still working with the Windows 7 version.