How to disable automatic track stretching?

I use Audacity to edit voice files, audio effects and other non-music audio files.

Previously, I would open Audacity, drag a file into it, and the file would open with no problems.

Now, for some reason, Audacity (3.5.1) always tries to stretch my clip to some arbitrary pitch. The rate at which it is stretched seems to vary depending on the BPM of the project.

I don’t care a single bit about this feature. I want to open a clip, click on Play, and hear what the file sounds like. I don’t want any automatic stretching, pitch changing, or any BPM related things.

I’ve looked at every single setting in preferences, and nothing seems to be closely related to this.

How can I disable this annoying feature? I don’t even care for BPM settings, since I’m not editing music!

click the gear in the top left corner and set the timeline to minutes and seconds (instead of beats and measures).

A lot of people want to know how to disable automatic time stretch. For some strange reason that I can’t fathom, the muse group developers omitted an option to turn it off completely. To prevent automatic time stretch:

  1. “Preferences > Import / Export > Music imports => Do nothing”.
  2. “View menu > Toolbars > Time Signature Toolbar = Off”
  3. Ensure that the Timeline (above the tracks) is set to “Minutes and Seconds”. If it is set to “Beats and Measures”, right click on the Timeline to change it.

Even if you get all that right, there may still be a chance that you encounter this bug: Audio Pitches Down/Up after opening an AUP3 project. · Issue #6611 · audacity/audacity · GitHub

The most reliable way to avoid pitch stretch problems is to use an older version of Audacity.

Hello Leo Winterberg

Well, that worked, but why?

Changing the time display should just change the time display. Why the time display is in any way related to time stretching is very puzzling.

Honestly, I didn’t even know this button existed. If you really think this is the right and intuitive way to do this, at least put this in the preferences menu, where people go to, you know, change their preferences, like the time display.

On a related note, I have no clue what the use case for this automatic time stretch is. I have used other DAWs and many other creative tools (images, video and audio), and this is the only one where dragging a file into the program doesn’t simply put the file into it.

You guys are probably uber geniuses for whom this is obviously working as intended, but you may want to do some usability testing on your software before making breaking changes like this one.

Anyways, thanks Mr. Winterberg and Mr. Steve. I seem to be able to work again, and if I have other issues in the future, maybe I’ll go back to a previous version like Mr. Steve suggested.

Changing the time display should just change the time display. Why the time display is in any way related to time stretching is very puzzling.

I’d agree with that. Eventually we want to have workspaces which have per-workspace settings for things like these. We didn’t have the resources to make that happen yet though.

On a related note, I have no clue what the use case for this automatic time stretch is. I have used other DAWs and many other creative tools (images, video and audio), and this is the only one where dragging a file into the program doesn’t simply put the file into it.

Tempo detection is a standard feature across most DAWs. The use case is when you make music and want to use a sample or loop that’s in a different BPM in your project. As such it’s vital for the entirety of electronic music.

That is a very specific use case that I’d argue you wouldn’t want to enable as default.

I’ve worked with Cakewalk and Audition, and when dragging a random audio file into the project, it doesn’t automatically stretch the time of the clip you put in it. Maybe they have a feature to do this, but I’ve never needed it, so I haven’t come across it.

Maybe the EDM folks love this new feature, but speaking for myself, I can definitely live without this.

This topic was automatically closed after 30 days. New replies are no longer allowed.