How to change to channel 2 when it's not shown as an option?

I’m using Audacity 2.1.0 on Windows Vista. I have been recording music from records. Now I’m trying to record from cassette tapes on a converter I just bought, but they sound warped on Audacity (even though they play normally on a Sony player). The converter manual says to set the recording device to USB Audio Device and channel to 2 (Stereo). But these options aren’t available under my “preferences”. There is only channel 1 listed, and either primary sound capture driver or microphone for recording device. I saw on this forum to set it to microphone for tapes–is that correct? Also, as I said, there is no channel 2 in sight. Please help.

Look in the Recording tab of the Windows Sound Control Panel and ensure that the device is set to 2 channel recording - you may need to also turn down the recording level very low (Windows often thinks that these devices are mono microphones).

Thanks. I changed it to channel 2 and USB audio CODEC, but when I try to record a tape it now says, “Error while opening sound device. Please check the recording sound settings and the project sample rate.” What the heck does this mean?

Where did you change that, in Audacity’s Device Toolbar?

You have to select the USB audio CODEC as recording device, 2 channels, in Device Toolbar, and set that same device to 2 channels in Windows Sound. Restart Audacity after making changes in Windows Sound.



I changed it in Windows Sound. I don’t see a way to change it on the audacity toolbar or under preferences–that’s the problem I’ve been trying to solve. Neither one gives the option of channel 2, only 1 (mono), nor of USB Codec, only either “microphone” or “primary sound capture driver”.

What is the make and model number of this converter? Do you have any other USB audio recording devices connected to the computer and might you have changed that other device to stereo and Windows does not even recognise the converter?

I suggest you quit Audacity and try the procedure in the green box “Detecting USB and Firewire devices” on this page:

Then reboot the computer and restart Audacity. If you still have problems, open Help > Audio Device Info… top right of Audacity. Right-click in the window that appears and “Select All”. Right-click again and “Copy”. Paste that information here.

Also - do you need this converter at all? If you have a Sony tape deck and the computer has a blue line-in input separate from the mic input, you can connect the tape deck to line-in of the computer. This is a question if you have that physical blue input on the computer. If you do, you may still have to enable it in Windows Sound.