How to change pitch without creating echo?

Need help. I’m trying to change pitch (say, by two half-steps down) of a MP3 music file. The problem is that this automatically creates a nasty echo. This problem continues even if I make adjustments to the echo effect.
I spent hours researching the problem, and more hours struggling to fix it. My testing efforts included Windows Vista, XP and Linux (Ubuntu); Audacity 2.0.0, Audacity 1.2.6, Audacity 1.3 Beta; plus some fiddling with my audio equipment on three computers.
My current Audacity 2.0.0 settings are: Audio Host = “MME”; Output Device = “Speakers (Realtek High Definition)”; and Input Device = “Stereo Mix (Realtek High Definition)”. Changing the Input Device to “DigitalIn (Realtek High Definition)” somewhat reduces the problem. Realtek is a corporation that, among other things, provides audio and network solutions.
By the way, I had installed Audacity 2.0.0 from the audacity-win-2.0.exe installer.
Thank you,

Hi Ian,

I’m using Audacity 2 on a Windows XP desktop.
I’ve just opened a previously recorded MP3, changed the pitch by 2 semi tones down and checked. No echo problem.
I’ve also in the past used ther change pitch by up to an octave down on a violin part to give a chello effect again no echo.

I’m using effect, change pitch without changing tempo.

Can you post a little bit of what you consider “echo?”

You have two really big strikes against you right away. You’re well beyond the number of piano notes you can shift without people catching you at it on a voice, and no matter what you do, the multiple MP3 compression distortion is going to kill you when you export your final show.

So you were in damage control before you got up this morning.


Attached are two short samples:

you will notice the strong echo (reverberation).

I don’t. The second cut just sounds like the original pitched downward. There is compression damage on that sustained note about 2/3 of the way down, but you can cure that by not using MP3 any more.

Do what we’re doing. Start Over. Restart the machine. Open Audacity fresh and open that second cut. If it’s still bad, try playing it in Windows Media.

Are you listening on headphones directly out of your sound card? No special effects or Environment Processing/Concert Hall stuff?


Try changing the pitch using the “Sliding Time Scale/Pitch Shift” effect. It is slower, but higher quality than the standard “Change Pitch” effect.

I hear it, particularly between 7 and 9 seconds where it sounds like a rhythmic rumble. Unfortunately I have no idea what you can do to get rid of it.

It’s an artefact of the Change Pitch algorithm, which I think uses a synchronized overlap-add algorithm.

The “Sliding Time Scale/Pitch Shift” effect uses a different, more complex Subband Sinusoidal Modelling Synthesis algorithm which is largely free of these artefacts.

I think what damage there is, is equal parts processing damage and MP3 artifacts. The poster is not using crystal clear WAV captures for all this. They’re using MP3. “Hidden” MP3 damage causes enormous problems when you start taking music apart and processing it.

Another problem was the poster’s insistence that the problem is the end of life as we know it.

this automatically creates a nasty echo.

When it took three of us straining to hear the damage.


Thank you all very much for your help!
My goal was to lower the pitch of over 100 songs so a choir (poor souls) wouldn’t have to strain their voices so much. I’ve been struggling with this issue for three months, and was getting strong echo no matter what I did.
Now, to my thrilling surprise - after I asked for help, and posted the two samples so you could hear what I was talking about - there is basically no echo! None in Audacity, none in the samples I sent you, and none in the songs I had modified (pitched down) and sent to disk months ago!!!
Beats me! The only thing that comes to mind and might explain the puzzle, is this:

  • I created the two MP3 samples in Audacity (the first unchanged; the second having its pitch down).
  • Then I made a change to either Audacity’s or Window’s settings (I didn’t think this was a significant or related change, and I can’t remember what change that was).
  • Then I submitted the samples to the Audacity forum.
    Sorry for the confusion I caused; long live the Audacity! :slight_smile:
    Thank you,
    Ian Chara

Many sound cards on Windows have “Environmental Settings” that can add special effects to audio playback, ranging from a simple Equalizer effect, to “Grand Canyon Echo” and “Concert Sound” effects. Windows Media Player also has special effects, including their “Wow effect”. Perhaps one or more of those effects were enabled and now turned off.

My previous comment still stands, “Sliding Time Scale/Pitch Shift” effect will produce a higher quality pitch shift effect, though it takes longer to process than the standard “Change Pitch” effect.