How do i remove background noise?

can anyone tell me how to record from my decks into a mac without picking up all the background noise? The mic is picking up everything. I guess i need to disable the mic, but when i do that it doesn’t pick up the sound coming from mixer either. I’m doing it through the griffin imic, and same happens when i plug the jack straight into the mac.

Does your Mac have connections that look like this…

Then you can plug your decks or mixer directly into that circle with two black arrows. That’s how I made this recording:

If you have one of the newer Macs missing Stereo Line-In, then you need an external sound device. I use the Behringer UCA-202 and that seems to work perfectly.

That also gives me a headphone port so I can do overdubbing and sound-on-sound. It works with any of the three computer types.

A Griffin iMic should have a place to plug an 1/8" stereo plug.

And a way to switch between high level and low level (Mic or Line) something like that. Switch to high level or Line.

Plug in the iMic and make sure the Mac is settled down and then launch Audacity. Audacity checks for devices when it starts.

Audacity > Preferences > Devices > Recording: Look for “USB Device,” “Griffin,” “iMic”, or something like that. If you’re completely at sea, unplug the iMic and see which device vanishes from the list. That’s the one.

After you select the right thing > OK > back out to the Audacity main window and press Record. Play a record.

You may not be able to hear it, but if you have blue waves and bouncing red meters, you are getting a recording.

To hear what you’re doing:

Audacity > Preferences > Recording > [X] Software Playthrough (select).

I have had very bad experiences with the Griffin iMic and I wouldn’t be shocked if it either didn’t work right or sounded bad.


If any of these steps fails, note exactly what you were doing and what failed. We’re going to ask you.

I missed one. If you do have that strange circle with two black arrows on the side of your Mac, then use that and:
Audacity > Preferences > Devices > Recording: Built-In Input, Stereo. > OK.

Play a record and press Record. If you can’t hear it, see above instructions.

There’s also the possibility you’re trying to do something your system won’t do. Talk to us.


Hi Koz.
Thanks for your help.
My Mac does not have the 2 arrows, just the headphones.

When i go to Audacity, preferences, recording, it shows me 3 boxes: play through, latency, sound activated recording. No ‘USB device’.
On the main Audacity page where i record, there is a speaker symbol and a mic symbol at the top of the page. In here I can choose ‘imic usb audio system’, or ‘built in output/mic’ (also ‘airplay’ on the speaker symbol). I have both set to imic, but when I hit record it says ‘Error while opening sound device. Please check input device settings and the project sample rate’. Is this where my problem lies?
Please advise.
Thanks again!

Apple (upper left of the desktop) > System Preferences > Sound > Input. Is the iMic listed there? Select it. Does the little sound meter jump when you play music?


Sorry for delay.
Yes, it does, and I think I’ve (almost) fixed it.
When I opened audacity with imic all plugged in and set up, recorded, it worked fine.
But as soon as I stop and try to record a new track it says ‘Error while opening sound device. Please check input device settings and the project sample rate’ again.
When i close audacity and start again afresh, it works.
I suppose I can get by like this, but now I’ve come this far, can you tell me how to fix this last little problem?

Try turning off Overdub in the Recording Preferences.