How do I get Track Navigation Cursor to not snap

I have version 2.0.0, on Windows 10
This used to work fine but somehow the behavior has changed. I am very new to Audacity…sigh.
When editing a track, I want the track navigation cursor to go to exactly the time I select with my mouse, but when I click on the waveform it snaps to the nearest 1 second interval. How do I change it to the default behavior?

Thanks in advance.

Maybe turn off “Snap To:” lower left.


Bingo! Thank you very much.