How do I get the inputs and outputs sorted?

Hi there.

I have Audacity 3.05 running on Elementary OS Odin (Linux) and I have an Allen and Heath USB mixer and a USB mic plugged in (sometimes). I’ve done the rescan thing in the transport menu and restarted the comp quite a few times but it seems like every time I try and choose inputs and outputs it’s different. Sometimes it’s obvious what’s what, sometimes I have a list of numbers, right now there are 24 entries in the input drop down
Screenshot from 2021-10-20 13.48.55.jpeg
But it’ll probably be different next time. It’s using ALSA. By choosing every entry one at a time I have found combinations that work but I can’t do the trial and error thing every time. Sometimes I get an error about mismatched sample rate (-9997).

The model above my HDMI monitor has speakers.

If anyone can shed some light on this, it would be great.

For Ubuntu based distros, you can usually leave Audacity set to record and play back from “default”. Then use the system’s audio mixer (or “PulseAudio Volume Control”, aka “pavucontrol”) to select the required hardware device.

Note that to see Audacity in the audio mixer / pavucontrol as a recording app, Audacity must be “monitoring” (Click on Audacity’s recording meter).

pavucontrol.png

I have set the in to ‘default’ but trying to enable monitoring triggers error -9997 invalid sample rate. I see no way to change the sample rate on the usb mic and the project is set to 44,100 the safest of all sample rates I assume…

Try 48000 Hz.

Tried all sample rates and got the same error.

Is there an option “Pulse” in the recording devices settings of the Device Toolbar? If so, try that instead of “default”.
(“Default” should be exactly the same as “Pulse”, but perhaps it isn’t on your computer).

No sign of the pulse setting today but it may have been there before, it varies…

Not sure if it’s relevant but music always plays fine through the mixer into the speakers and I get level in the sys prefs when I tap the mic, so long as it is selected as the input.

Let’s see if you have pavucontrol installed and working.

  1. Press “Alt + F2”
  2. Enter: pavucontrol
  3. Click the “Launch” button.

What happens?

Alt F2 doesn’t do anything on Elementary, not at least on mine, but pavucontrol entered into the terminal or whatever it is on Linux, launches a sound control panel with a few sliders and port choices.

That’s bad :smiley: (https://www.makeuseof.com/tag/alt-f2-ultimate-linux-keyboard-shortcut/)


Super.

In the “Configuration” tab, what is selected?

Sorry for the late reply.


Screenshot from 2021-11-04 17.57.56.jpeg

Wow, you’ve go a lot there.

I assume that you want to record from the Allen & Heath?
If you disconnect the A&H, you should see one of those options disappear. Which one disappears?

I’d like to record from the A&H, the Helix or the AK5370 mic, it just depends on what I’m doing. If I connect or disconnect anything, it appears/vanishes from the pavucontrol panel quite reliably, getting a similar reliability from Audacity is the aspiration…

After making any changes to the connected devices, you need to either restart Audacity or “Rescan Audio Devices” (near the bottom of the Transport menu).

I have tried all those but the problem is that the menu items are always different and seem to vary bearing little relation to what is actually connected.

The next thrilling installment of my Audacity input/output troubles is here! The I/O situation has settled down now and despite gadgets being connected or disconnected they stay as shown in the pictures.
Aud1.jpeg
Aud2.jpeg
No amount of ‘scanning audio devices’ or restarts has any effect. Are there any cryptic commands that can be typed into the terminal to move things along?

Thanks.

I use a midi patchbay called both aconnectgui and ALSA Sequencer, if that’s relevant.

I don’t think I can help you. Your computer has an extremely complex audio setup with SIX separate audio devices.
This is what a more typical configuration in Pulse Audio looks like:

pavucontrol.png

I have disconnected all but the Line 6 Helix and the USB mic, this is the problem, the I/O drop downs don’t reflect the physical devices connected, in post 1 I had 24 devices connected according to Audacity! The Helix has never shown up in Audacity despite being my only audio interface now and the mic has put in an appearance this morning for once, but it won’t be there when I need it. Even the number of entries for the HDA intel PCH thing changes from one day to the next.