How do I connect speakers & microphone to PC? Total Newbie!


I just found this forum and hope someone can help. I need to hook up a pair of speakers to my PC and also a microphone so that I can make voice recordings. I tried just plugging them both into my PC but nothing I tried worked----could not get any sound.

I know the speakers work because I can hear through them when I play a CD in my CD-ROM. The microphone also works when used with my old stereo/record player system to make cassette tapes.

Can anyone help me get them working? I must warn you that I am a COMPLETE novice when it comes to anything like this. I know absolutely NOTHING so any replies will have to be very, very simply explained to me.

Thank you very much,

Getting your audio up and running in a computer environment is not something that can often be broken down into really simple steps. There are a myriad of different ways to write software and to build hardware, so you’ll almost always be required to know how to do basic things yourself. We can’t help you with stuff like that.

The good news is, your speakers are connected just fine if you can use your computer to play an audio CD. The microphone is a different story though.

What kind of microphone is it (a model number will help)? Does it have an XLR plug or a jack plug? If it’s a jack plug, is the plug 1/4" or 1/8"?

If your mic has an 1/8" jack plug, you can probably plug it directly into your computer’s Mic In port. Usually (but not always) these are colored pink. If that’s true, then once you plug in your mic you need to open Audacity and click edit → preferences → audio i/o tab. At this menu, under “Recording” select Mic In as your device. Also, make sure “Software Playthrough” is turned OFF. Then you can click ‘OK.’

At that point, from Audacity’s main screen you can click record and you should get something recorded. While you’re recording you’ll need to either wear headphones or simply turn off the speakers to avoid feedback.

If you have a different kind of microphone, let us know what it is. You might need to buy a mic pre-amp in order to use your mic.

Thanks so much for replying!!!

Here is some more information.

My speakers work when playing a CD and they are plugged into the front of the computer by the CD player. They don’t work to play a CD if I try plugging them into the back of the computer in the green jack.

When I plug the speaakers into the back of the computer into the green jack, no sound comes out of them. I tried downloading and mp3 file from the internet and plaaying it, but no sound came out of the speakers.

My microphone says:
Highball 2
Dual Impedaance

It has some kind of adaptor on the end and it fits right into the jack on the back of the computer. I plugged it into the pink jack.

Then I opened Audacity went to edit → preferences → audio i/o tab, but under “Recording” there is no option to select Mic In as the device. It only gives me 2 choices. One says “Microsoft Sound Mapper-Input” and the other option is “VIBRA 128 record”. What do I do now???

“Software Playthrough” is turned off.

Your microphone is a “dynamic mic”. Although general purpose sound cards are designed to use a different kind of microphone (electret microphone), it should still work ok.
The pink socket is the correct one, although you will probably find that the sound quality is not particularly brilliant as most general purpose sound cards have fairly poor quality microphone inputs, but for voice recording it will probably be sufficient.

Either of these should work, so select one of them and try the following - if it doesn’t work, try the other.

You need to open the Windows Mixer - double click on the loudspeaker icon in the bottom right corner of the screen (near the clock). The Windows mixer should now open. Go to the “Record Settings” page (from “Options”), and set the microphone as the recording source - make sure that the level is turned up and you may need to tick the “+20dB boost” check box if there is one. If there is no microphone input listed, you may have to go back to the options menu to un-hide it.

Hopefully you will now be able to record, although you will still need to adjust the recording level, which you do with the slider that microphone slider we looked at earlier in the Windows Mixer (record section).

You may also find this page useful:

Thank youso much for trying to help me!

What is the “Windows Mixer”???

When I double click on the loudspeaker icon in the bottom right corner of the screen (near the clock), the box that opens is called “Volume Control”. It has a bunch of ‘slider’ controls and boxes to mute the sound. The “Advance” option on it only has sliders for “Tone control”. (I have Windows 98 in case that makes any difference). Where do I find the “windows Mixer” aand the “Options/Record Settings”??


I forgot to mention that I am now getting the common “Microsoft sounds” out of my speakers since I moved all the sliders to the very top in that “Volume Control” window. There wasn’t any sound at all before I did that.


It’s been quite a while since I’ve used Windows 98, but I don’t remember it being much different from XP in this regard. The “Volume Control” window is actually the “Windows Mixer,” though why it never says that anywhere is a mystery to me. So any input source you have selected in the Volume Control window will be routed to the Windows Mixer source when you use Audacity.

This page will be of some help, scroll down a bit to the section about Windows XP, the windows will probably look pretty similar. Start with the second XP photo, there’s text that says “and select your input by putting a mark in the check box”

So, open the Volume Control window again and it should look pretty similar to that picture. Click options → Adjust volume for ‘recording.’ Now, click OK. The Volume Control window should have changed a little bit, now it’s showing you the input volume for all the possible inputs you can access. Select the Mic input and make sure the volume is up (set it to the middle for now, you can always come back and adjust it later). Now, when you select “Windows Mixer” in Audacity, you will actually be recording from the Mic In.

Hi, I’m back. I hope there are folks here who can continue to help me…please :slight_smile:

I looked at all the things mentioned already but my “loudspeaker” icon just doesn’t have the things such as “options → Adjust volume for ‘recording.’” When I click the Options tab in the loudspeaaker ‘Volume Control’, it only gives me the choices of 'Properties, Advanced Controls, or Exit". If I click on the Advanced button, it only gives me “Tone Control” sliders. Soooo…I’m lost about this part. I have all the volume sliders annd tone sliders in that loudspeaaker icon turned the whole way up.

But, I have figured out how to use audacity to play an mp3 file that I downloaded from the internet. I can hear it ok, but it isn’t real loud ---- just barely loud enough to be able to hear it.

But, when I try to listen to that mp3 file by going to it directly on my hardrive and just clicking on it to open it, it opens in the Windows Media Player…but I can’t hear anything. Any idea what is wrong here???

Also, I have searched and searched and read and re-read the help files and tutorials on Audacity but cannot figure out how to start making a voice recording. What do I need to do???

THANK YOU to anyone willing to continue helping me!!!



You want to click in the properties button not the advanced. Then you should be able to see the options as in the link provided by alathan

. What you want is shown in the last picture in this link where it shows you to click on recording and not playback.

Click on recording and tick the boxes of the inputs you want displayed. click ok and a new lot of volume sliders wil appear. if you are using the line iin then adjust the slider for this, if you are using the microphone port then adjust this one.

hope this helps

You can adjust the volume in audacity by increasing the gain. there is a slider for this on left hand of the track you just imported or recorded. it is above the pan slider. There are other ways to increase the volume also such as normalise and eq but i suggest you read the tutorials as it will be faster than me explaining here.

What does the waveform look like of your imported file. If the peaks are very small then that will be why your sound is quiet. if there are quite large (extending vertically to -3db or higher) then there may be something wrong with your playback volumes not audacity.


To select microphone (if this is where you are plugging into your computer) then this is not in preferences but on the main page when you open audacity. You should have a slider with a speaker icon, then next to that, a slider with a microphone icon and then next to that there should be a small box with a dropdown menu that will give yoiu the option to record with microphone or line in etc. select microphone here (again if you are plugged into the microphone socket. if you are plugged into the line in then select line in). Once you have selected this make sure that the slider with the microphone icon is at least half way over. if this is all the way to the left then you probably wont get any sound. then follow stevethefiddlers advice

. and it should be a case of just pressing record in audacity and talking into the microphone. If you see the record meter lighting up then youve got sound going to audacity. If the sound is still quiet then increase the slider with the microphone icon further or if this isfull and you still only have low volume, check you windows setting as has previously been explained.

To see a picture of the sliders and the drop down menu that i have mentioned go to this link and you can see them. they may look slightly different or in a different position on your computer but they will essentially be the same.

good luck i hope i have helped a little

Thank you so much for all the help I received here!!! Everything is finally working and I am able to make the voice recordings. As it turns out, I discovered quite by accident that the problem I was having with not being able to hear an mp3 file play through my speakers was due to the fact that I didn’t know that I had to unplug my headphones and then plug the speakers in where the headphones had been. I was just trying a bunch of different things and stumbled onto my ‘solution’…LOL!!! (Told you I was a real newbie to this audio stuff. )

Seriously though, I do greatly appreciate all you did to help with getting everything set up and working.