How do I avoid or remove "hollow" sound from captured recording of streaming audio?

My streaming audio is accurately captured but acquired a slight "hollow’ sound in the process. This seems to result from a mild reverb since adding any reverb effect multiplies the hollowness ten times over. How do I reduce or remove this mild reverb?

“audio enhancements” can be on by default, and can add a pseudo-stereo effect which has a hint of reverb. If you are recording the speakers (loopback) any “enhancements” are baked-in to the recording.

https://support.microsoft.com/en-gb/topic/disable-audio-enhancements-0ec686c4-8d79-4588-b7e7-9287dd296f72

Thanks Trebor. Unfortunately, my Windows 11 system does not match the directions on that page. I have no Device Properties menu under Settings > System > Sound > Microphone. I have only General, Input settings (Format, Input volume, Test your microphone). I see no option anywhere to disable enhancements. I searched the control panel for “audio enhancements” and came up blank.

I found another page with better instructions: How to manage sound settings on Windows 11 | Windows Central. Finally, I found the setting to disable audio enhancements on the speakers. But I’m recording the streaming sound directly, no via the microphone. Turning off those enhancements didn’t change a thing. So I’m back to square one.

loopback records what the speakers are playing via internal electrical connection, not via the microphone.
But If you’ve disabled playback enhancements (speakers) and the problem persists, enhancements can’t be the cause.
[There can be a second layer of audio enhancements, sometimes called MaxxAudio].

So it’s captured with good stability, but not accurately.

That note about adding reverb is a good start.

In order to capture streaming sound, the system has to run both the Playback and the Recording services at the same time and jam them together. Anything in either pathway can affect the recording.

Is this a laptop? Do you know where the built-in microphone is? Do a test recording and scratch the microphone. Can you hear the scratching in the recording?

Do a test recording and turn the speakers or headphones off during the capture. Did the problem vanish?

Make sure there’s nothing else running on the machine. Do a Clean Shutdown. Shift+Shutdown > OK > Wait > Start. Don’t let anything start.

Did the problem change? Any change, good or bad is noteworthy.

Koz

This topic was automatically closed after 30 days. New replies are no longer allowed.