high pitched background noise

I’m trying to make an audio recording of a presentation on windows 7.

The recording quality is excellent for my voice, but I can’t figure out how to get rid of a constant high pitched squeaking sound. I’m using a mic… but this sound is there whether I record something or just leave it silent. Do you have any suggestions on how I can set audacity up so all I hear on the recording is my voice?


This is a guessing game at the moment.
Laptop computers have a habit of producing a high pitched whistle due to interference from the power supply. The most simple “cure” is to run the laptop on batteries.

If that’s not it, could you give details of what equipment you are using, how it is set up and what you are doing (step by step).

Clock noise ? , which can be removed by notching …

If it is clock artifact then a spectrum of a “silent” bit will have spikes at reqular intervals …
clock noise and harmonics.png
The spikes can be removed with a notch filter …
Notch filter#2 plugin for Audacity,( NY in ZIP).zip (628 Bytes)
BTW for some reason notching does a better job at curing this problem than Audacity’s noise reduction.

I think the problem was with my mic. When I unplugged it and just recorded straight to the computer, there was no background noise… however… sound quality was not nearly as good. Is there a recommended mic that is commonly available? I don’t know what to tell you about “step by step” other than I open the software, press record, and play back with the high pitched background. It doesn’t seem to matter how many hertz, or bits. Thanks for your prompt reply!

Possibly external mic is picking up mains hum, although that’s more of a buzz than a high pitched whistle …

Possibly feedback squeal (that’s usually high pitched) …

You can attach a few seconds of the affected audio to your posts here, provided the file size is less than 1Mb,
we might be able to diagnose the problem from your audio sample.

here’s the attachment sample

Oh dear, there is something seriously wrong there. My first thought is that your sound card is faulty.

What sort of microphone/sound card/computer/operating system are you using? (model numbers are useful)

The boiling kettle whistle is removable with the notch filter I posted above …

But there is something fundamentally wrong with your recording
the 0.07second pulses every half second and the effect which follows half a second after you speak suggest to me that an AGC/compressor may be the cause.

It may be possible to turn off this AGC/compressor via software (unchecking a tick box) and alter the gain (sensitivity level ) manually via an on-screen slider.

These controls may be under “Microphone enhancements” in “microphone properties”…
Microphone properties-Vista.png


could there be skype or other software lurking that is causing the problem ?

I tried everything that was posted, and nothing has worked so far… can’t find AGC compressor to check/uncheck but I did spend a lot of time browsing in microphone settings. I have a Toshiba Satellite A505-S6980 with Windows 7. Intel core 2 Duo T6600. I do have skype installed on my computer, with video/voice calling. If that is the problem, how do I turn it off?

If Skype isn’t running then I can’t see how it could be the cause of the problem.

The only other thing I can suggest is lowering the “levels” on “microphone properties”, if Window7 is like Vista it will be a couple of on-screen sliders …

Also if you have another microphone you should try that just to see if the problem is microphone specific.

BTW just found this in an Amazon review

When Windows XP built-in USB sound card driver is installed, > AGC checkbox is avaialble in advanced mic property dialog box> .
When C-Media USB driver is installed, AGC is gone and Microphone boost (+20db) option shows up.

So apparently the AGC tickbox, if it exists, is in the “Advanced” microphone properties, not “Microphone Enhancements” as I stated earlier.

Skype can cause recording problems, but not this sort of problem. I also very much doubt that it is caused by AGC or any other setting. The signal that is being recorded strongly suggests faulty hardware. If you’re using a USB microphone, try it on a different computer and if you get the same problem, send it back to where you got it from or throw it away. If you’re using a conventional microphone (with a little round jack plug), try a different microphone.

This worked for me and might work for you. [Explanation for Windows XP - working on an old PC right now.]

1.) Open your volume control in the taskbar [Bottom right-hand side.)
2.) Click options → properties
3.) Under “Adjust volume for” set the button from playback to recording, and click OK.
4.) Click advanced
5.) Under “Other Controls” disable the AGC.

AGC caused a massive volume burst and thus amplified the noise.
See the attached image if you feel my steps are bad :slight_smile:.

Good luck!
audacity-microphone pitch.PNG

Thanks for your comments Diablofire, but this topic is well over three years old so I doubt that the original poster will still be around.