Help with Roland EDIROL FA66 Audio Capture into Audacity

I’m using a Roland EDIROL FA 66 Audio capture unit, with Firewire input to the computer,
and data coding of WDM or ASIO . Sampling at 48Khz and using 24 bits signal processing.

This product works fine on my Apple Mac Pro using Garageband as well as Adobe Creative Suite CS4 capture.

I’ve installed Audacity 1.3 Beta on my PC: HP 32bit with 2.66 GHz 4 Dual core processors and 4Gb RAM. The O/S is Microsoft VISTA.
I can import and play sample WDM files from the EDIROL setup CD. The WAVE audio format plays just fine. From Audacity, I can play them on the computer speakers, and I can also play them through the FA 66 unit.

But when I play electric guitars through the EDIROL, I can’t get Audacity to recognise the input from the FA 66. I don’t get any signal even though Audacity recognises the FA 66 in 3 channels (1, 2 and
3), which equate to output from computer, input to computer and midi input to computer.

I’d really appreciate knowing whether I can use the EDIROL FA 66 with Audacity to capture
my music, and if so, how to make Audacity recognise the input.

Audacity is distributed without ASIO support (the ASIO license does not allow it to be distributed in open source software). To use the device with Audacity you must either, build Audacity from the source code and include ASIO support (not easy), or install drivers for your hardware that are native to your operating system. On a Windows System this usually means installing WDM drivers for the hardware.

Thanks Steve.
I looked at the settings and found that the PC was receiving EDIROL output from Channel 1. I set this into Audacity and it worked when I set the track to Stereo. I was using a Shure Beta 57A microphone in the EDIROL right channel only.
When I set the track to MONO, Audacity didn’t detect any input.

I see after typing this you have had some success, and as suspected mono gives problems, but I’m going to leave all the below in as it might help someone else.

You should make sure you have the correct Vista 32-bit driver:

however one part of the site has a link to a PDF:

that says the driver is incompatible with Vista. You should contact Roland support to discuss this discrepancy.

If the driver is valid, it apparently supports both WDM and ASIO. Audacity as shipped does not support ASIO so it should only see the WDM stream. You should record from “EDIROL FA-66 In 1” which should be input jack 1 and 2 on the device. Keep it simple to begin with and set the Audacity project rate bottom left of the window to 441000 and recording channels on the Devices tab of Preferences to “1 (Mono)”. On the device, set the sample rate select switch to match (44100 Hz). From the Manual “If you switch the FA-66’s sample rate, you must turn the power of the FA-66 off, then on again to get the setting to take effect.”

You want to also go to the Windows system mixer:

select the device on the Recording tab > right-click > Properties, and look around for any settings relating to channels and sample rates. There will probably be a “Default Format” setting on the “Advanced” tab. You must set this to match with the Audacity project rate and number of channels, and with the sample rate selector on the device e.g. 44100 Hz mono. Make the same change from the Playback tab.

If you are only connecting one input and the input volume recorded into Audacity is too low, try recording 2 channels (make commensurate changes as required elsewhere) then close one of the recorded channels in Audacity.

If you still have problems, try the “DirectSound” host in the Audacity Devices Preferences.

Also note the Roland site says “A FireWire(IEEE1394) control chip from TI(Texas Instruments) is recommended.Please download and open file then copy the fa66dv32_v105e folder onto your computer’s suitable directory. For the detail of this driver and the installation procedure, please refer to Readme_E.htm in the folder.”


Cool, glad it’s sorted. The mono/stereo thing is because of the way the sound card driver is written, so there’s not much you can do about that. If you’re getting one channel with sound and one channel without, you can use “Split to Mono” from the drop-down track menu (click on the track name), then delete the unwanted track.

I’m not sure if you’re seeing our replies to your e-mails sent to feedback@, so I am repeating this here.

If you send Audacity what amounts to a stereo pair with one channel lacking input, but ask Audacity to record that in mono, a lot will depend on the drivers of the device. In your case, you were connected to the right input, but asked for mono, and the device sent the left input which was near silent. Audacity can’t yet record a stereo pair as two separate mono channels, except by recording in stereo then using the track drop-down menu to “Split Stereo to Mono”.

Had you connected the left input, you would have recorded when you asked for mono, but you might find that you only got half volume. There are a few reports that Audacity 1.2.6 does not have this problem in exactly the same scenario and will record at maximum volume.


Thank you Steve and Gale. I do have the correct Vista driver but I didn’t know about the incompatibility with Vista 32 bit O/s. I’m going to upgrade to Windows 7, and hopefully things will get better.

I also didn’t know about the Firewire component.

The Audacity team rock :sunglasses: . It will be easier now to find my way through the discussions. This “in at the deep end” exposure has been good for me.