Help with Plugins - macOS Sierra

Hi all,

I just did a clean install of macOS Sierra and then reinstalled Audacity (audacity-macosx-ub-2.1.2.dmg). However, I can’t find a few plugins, for example limiter is missing from the plugin manager as well as in the drop down menu. I looked through the actual plugin folder and found it there but for some strange reason, it just doesn’t show up in the drop down or in the plugin manager (please see attached photos)

I then thought I would try downloading optional plugins and putting them into the plugin folder but that didn’t work either… I also notice the “nyquist” folder is not in the plug-in folder in the Audacity folder under applications, and was wondering why… I remember in the previous version I put in optional plugins under the plug-in folder and everything worked out well.

I use Limiter and Hard Limiter a lot and I’m not sure what I am doing wrong and would be grateful for any help.

Thanks in advance!
Screen Shot 2016-10-08 at 11.48.02.png
Screen Shot 2016-10-08 at 11.42.19.png
Screen Shot 2016-10-08 at 11.37.03.png

The “Nyquist” folder was never supposed to be inside the “Plug-ins” folder in your previous installation. The “Nyquist” folder should be alongside “Plug-ins”.

Hard Limiter no longer ships with Audacity. If you want it, obtain

Make sure you are not executing Audacity from inside the DMG because that prevents Nyquist plugins being detected.

Look at Audacity > Preferences…, Effects section and ensure you have Nyquist and all other plugin types you want checked off (ticked).


Hi Gale,

Thanks for your response. For my previous install, I’m not sure where the “Nyquist” was, but currently it is not in the plug-ins folder, but a separate one under the Audacity folder in the Applications folder.

I understand Hard Limiter is no longer available with Audacity, but currently, as can be seen from the above screen shots, there is no limiter at all.

I checked the Audacity > Preferences > Effects section and all plugins have been checked off / ticked. So I am not sure what I’m doing wrong.

When I installed, I transferred the dmg file to the applications prior to installation. When I open the program, I go to the application folder to open it, or launch it from launchpad.
Screen Shot 2016-10-08 at 23.16.34.png

You could quit Audacity, open Finder, use the Go menu, Go to Folder, open

~/Library/Application Support/

then trash the “audacity” folder.

Then trash the folder where Audacity is in /Applications and install Audacity again from



I also have just performed a clean install of OS X 10.12 (sierra) and have re installed audacity 2.1.2.
It now appears that Audacity doesn’t see the plug in folder at all. I have trashed the folder from application support and reinstalled as per the above advice.

None of the plug-ins from the plug-in folder inside the Audacity folder within Applications appear on opening Audacity nor are they available to be enabled from the add/remove plug-ins menu…

anybody had a similar problem? Found a fix?



It does not happen to me on Sierra.

Make sure you are not executing Audacity from inside the DMG because that prevents Nyquist plugins being detected.

Is it some new permissions problem in Sierra? Are you logged in as admin or standard user? I am logged in as admin. Can you post the Support Data ZIP file from Help > Generate Support Data… top right of Audacity?

Also look in Applications > Utilities > Is there anything relevant there?


Hi Gale,

Thanks for getting back to me so quick. I am logged in as admin, and Audacity was very definitely opened from within the Applications folder not the .dmg, after the .dmg had been unmounted. None of the plug ins are showing up, the analyst menu for example only contains “Contrast, Plot spectrum and Find Clipping”

I have attached the support file. I don’t really know what I’m looking for in Console -there are several Audacity reports- a couple of cpu resource reports, a couple of wake-up resource reports and one hang. If you let me know what would be useful I’ll put them up.


R (7.03 KB)

Thanks Gale. I have done this many times. I use App Zapper to uninstall and I have uninstalled an reinstalled many times over. I even tried installing the older versions and I have the same problem.

I am so glad I am not the only one. Yes, it seems like Audacity doesn’t see the plug-in folder at all. And even the effects that it does, does not include the limiter plugin.

Yes, I am logged on as admin. Are the plugins registry and plugins settings at the Support Data meant to be unchecked / unticked?
Screen Shot 2016-10-09 at 17.32.57.png

Put a checkmark by all the items. Any items that are unchecked are not included in the report.


Thanks, but there is not anything in it that explains why there is a problem.

I see that an entry like this which should be there:

Symbol=Nyquist Effects
Name=Nyquist Effects
Vendor=The Audacity Team
Description=Provides Nyquist Effects support to Audacity

is missing.

However support for the other plugin formats is listed there, so presumably poseidan would be able to use the LADSPA Hard Limiter.


The next thing both of you could try is to see if the 2.1.3-alpha Nightly Build has the same issue:

Be sure to quit 2.1.2 before running 2.1.3-alpha.

If that does not help, then open Applications > Utilities > Drag the 2.1.3-alpha into the Terminal window. Copy the below text:


then in the Terminal, LEFT arrow once to move the cursor to the end of the path of Audacity, then COMMAND + V to paste the above text.

Or you can right-click or CONTROL-click over, click “Show Package Contents”, expand the “Contents” and “MacOS” folders then drag “Audacity” from the “MacOS” folder into the Terminal.

Hit ENTER in the Terminal to launch Audacity and you may see some messages in the Terminal. Either copy and paste the messages from the Terminal to your reply, or in the Terminal’s Menu Bar, use Shell > Export Text As… to save the Terminal output to a text file.



Replaced 2.1.2 with 2.1.3, same issue…I’ll try the terminal thing no…

Thankyou for your help with this.


No text in terminal I’m afraid. Cursor just moves to the second line.

I could still pull reports out of Console if you give me a hint of what I should look for!


The Plug-ins are there!

opening audacity 2.1.3 from terminal somehow forces the plug-ins to be read!

I then quit Audacity, opened from the Applications folder and the plug-ins were gone again. Returning to Terminal and opening from there includes the plug-ins again.

Thankyou…a bit weird I guess… but it works. Would be nice if I didn’t have to go through Terminal, but it’s not the most difficult work around I’ve ever heard of!



This sounds a bit like issues one or two users have had getting Audacity to launch on El Capitan, which could be resolved by executing “Audacity” from the MacOS folder in the application bundle.

I don’t know what messages might be in the Console when the plugins don’t load. It could be something to do with plist files or there may not be any messages.

However another user who did not have Generate > Click Track (another Nyquist plugin) said the plugins appeared when restarting (I assume) the Mac: Definitely try that in case it saves opening Audacity by the Terminal every time. If restarting helps, perhaps Mac is not updating something immediately.

You can actually launch the Audacity executable in the Contents/MacOS/ folder an easier way - right-click or CONTROL-click over it, then choose Open With >, or even just double-click the executable. The Terminal will open then Audacity will launch. The only downside to this method is that after you quit Audacity in Audacity itself, you can’t use the terminal for any other input, all you can do is quit it. Next time you use the Terminal to launch Audacity, you can just use UP arrow to show the last used command, then ENTER.


Thanks Gale. They are all ticked. The plugins are still undetected…

Anyone with any solutions? Nothing seems to work after a clean install…

Thanks, the Terminal method works with 2.1.2. I am currently downloading 2.1.3 but I might not install it because it works now. This means Terminal needs to remain open while I use Audacity, yes?

Thanks anyway, Gale. Much appreciated!

Help > Generate Support Data… is for generating a ZIP file containing diagnostic information. It does not turn plugin detection on or off.


Yes. Quitting Terminal will force quit Audacity, so leave the Terminal open until you have quit Audacity normally from within Audacity.

Also please just try rebooting and let us know if that avoids having to use the Terminal. We don’t want to have to provide instructions how to use the Terminal for less able users, unless we have to.