Help with M-Audio Fast Track

I know there are like a gazillion posts out there on M-Audio with Audacity, but unfortunately none have been able to help me out.
I am running Audacity 2.0.1, Ubuntu 12.10 and pulseaudio…where the m audio card gets detected and no the input is not muted.
When I try to record, all I get is a flat line.
Under Preferences>Devices, I have host as ALSA, playback as default (have tried changing it to Fast Track:USB Audio (hw:2,0) with no effect) and playback as Fast Track;USB Audio(hw:2,0) and a number of options after that all of which I have tried.
Feeling quite lost…

I’m not sure what GUI Ubuntu are currently using for controlling the sound system, but there will be some sort of “control panel” for sounds - possibly right clicking on a speaker icon and selecting “preferences”. You need to find the recording input settings for your system, and then see if the system is recognising the input from your m-audio device.

This is from Debian - notice the blue recording level displaying in the meter, and notice the input device selection below it.
sounds.png

Here are my settings in Audacity using the M-Audio Fast Track II USB interface in LMDE. I’ve used Mint as well which is Ubuntu based. This is a sample instrument recording.

I’ve found that I can’t record in mono using the Fast Track. It must be in stereo for the instrument input records on one channel and the mic input records on another. In addition, there’s no difference in setting your output to Default or Fast Track. You should get sound either way… at least I do. However, the Audacity Output slider is rendered useless in either case.

Steve and Lawrie, thanks for your inputs.
I too discovered that it records only in stereo mode. The problem now is that when I import a guitar backing track and try to record my guitar along with it, it sounds very broken, after sometime becomes ok for a while and then back to broken…the cycle continues and as always, I am clueless again :slight_smile:
Also, in a bout of sheer frustration, I went and uninstalled pulseaudio after which my laptop’s soundcard doesn’t seem to be working. Situation remains the same even after reinstalling pulseaudio, though I am able to get output from the m audio card as playback in Audacity.

Try this:

On the premise that that ALSA is the audio host in Audacity, I would suggest installing an ALSA mixer (if you don’t already have one). Go into Synaptic Package Manager and search for “mixer”. A whole bunch will show up. I’m using the xfce4-mixer (I have XFCE DE installed but using Cinnamon) however, you may have to experiment with a few.

I’ve found that using an ALSA mixer provides more menu options for record and playback in Audacity which may help with your problem. Lastly, keep all you Pulse Audio software installed. The ALSA mixer will not impact it… at least it doesn’t for me.

The command line version of AlsaMixer is installed by default in every Desktop Linux distribution that I’ve come across. It has a very basic “graphical” interface within the terminal window, but it has access to all inputs and outputs that are supported by the ALSA drivers. To run Alsamixer, open a Terminal window and type:

alsamixer



This is a “feature” of the Fast Track, and is common to most pro and semi-pro sound cards. Input one is allocated to channel 1 and input 2 is allocated to channel 2.
In full featured DAW applications (such as Ardour), you can “map” any available input to any track. Audacity does not currently have “channel mapping” so input on channel 1 always goes to either “mono” or “channel 1” (left) for a stereo track and channel 2 always goes to channel 2 (right) of a stereo track.
The Fast Track Pro allows either mic on instrument input on both channels 1 and 2, but unfortunately (to keep the cost down) the original Fast Tracks only had mic on channel 1 and instrument on channel 2, so to record the instrument channel (channel 2) in Audacity you have to record in Stereo, then split the track to mono and delete the empty track. (see here for how to split tracks: Audacity Manual)

To control the input level, use the controls on the Fast Track - that’s what they are there for.

Noooo :astonished:
Don’t do that. PulseAudio is plumbed deep into the system in modern Desktop distributions. Removing PulseAudio is likely to break lots of things. Unfortunately there is a lot of disinformation on the internet, dating back to the early days of PulseAudio (when it was quite flaky) suggesting that PulseAudio should be removed - ignore such comments, they are out of date and dangerous to the health of your system - PulseAudio should not be removed.

Try a different USB port and reboot the computer.
Do not use a USB hub.
Avoid running processor intensive applications at the same time as Audacity.
Ensure that you have plenty of free RAM.
Avoid running other audio applications at the same time (especially web browser pages that have Flash content).
Avoid making heavy use of USB other than the Fast Track (a USB mouse should be no problem, but a USB web cam could be).
Use the “hw:(1.0)” inputs rather than “default” or “Pulse”. Depending on your set-up there could be multiple options to try.
Try both 44100 and 48000 as the default sample rate in “Edit > Preferences > Quality” (leave the other “Quality” settings at default).

If you have been fiddling with Audacity Preferences while trying to get this working, please say so and we can try resetting the preferences back to factory defaults.