Help Needed Recording Vocals Alone When Using Backing Tracks

I am using the Audacity version 2.0.5 on Windows 7, via the .exe installer.

My current issue is how do I make vocal recordings without the backing track being played while I record? I want to only record my voice, but it seems to record the backing track as well when it is playing back. My recording setup is a CAD GLX2200BP microphone and the Behringer Xenyx Q502 USB sound board.

You’ve not really given enough information for us to guess what is wrong with your setup, but the information in these tutorials may help: http://manual.audacityteam.org/o/man/tutorial_recording_multi_track_overdubs.html

What I am wanting to do is record only the vocals when I have uploaded an instrumental track, but whenever I try, the instrumentals are recorded along with the vocals. This then creates a track with the vocals and instrumentals, along with the instrumental track I uploaded. This is not what I want. I want to know if there is a way to record the vocals only and not have the instrumentals record. Of course, there would still need to be a way to hear the instrumentals so I can be sure of staying in sync with the song. I thought overdubbing would help solve the issue, turning off that feature that is, but whenever I play the song via other means, it still records all of the instrumentals.

I do hope I am making sense.

That’s a little rough with the information given.

Audacity > Edit > Preferences > Recording: [X] Overdub should be the only thing selected.

Koz

Dueling posts. I got out of step with the messages. Did that help?

Koz

Overdubbing is something I have tried, I tried once more, and it did not give me the results I was searching for. However, I did use my iPod to play the backing track while I recorded only my vocals, the track I uploaded to Audacity I merely muted so it would not record while I recorded vocals.

Thank you for your assistance.

“Transport menu > Software Playthrough” OFF (not selected).
/
device toolbar: Recording input set the the USB mixing desk.

Where are your headphones plugged in?
You’re not using speakers are you?

This is exactly what I was looking for but what are the solutions here?

I am running 2.0.5 .exe on Win7 64bit
SM58 → Q502USB connected to my laptop.

Scope:
Record vocal to the backing tracks.

Issue:
When recording vocal, backing track gets recorded with the vocal sound.

Audacity > Edit > Preferences > Recording: [X] Overdub is the only thing selected.
Mic and speaker (headphone to Q502USB) both selected to the device.

BEHRINGER_2902_X64_2.8.40.zip downloaded from http://www.behringer.com/EN/Support/U-Control-Downloads.aspx
which I am hoping is the right driver.

Ensure that you select the microphone and not “Stereo Mix” or “Sound Mapper” as the recording input in the device toolbar.

Okay, I am lost.
When [To Main Mix] on the 1st pic is pressed down, I get the backing track and my vocal recorded (Red line on the last pic).
When release, no backing track and I only get my vocal sound recorded. (Green line)
Please advice. Thanks!
IMG_0061.JPG
cap1.JPG
cap2.JPG
cap3.JPG

Hi,

I’m new to the forums but I’ve been recording and editing for a long time.

Just glancing at your posted photos, I’m going to say this is not an Audacity problem, it’s a mix problem. If I understand correctly, you want to hear the music and your voice at your headphones. You’re recording to Audacity from the Main Mix output. When you press that button down, it sends the USB signal to the Main Mix, and anything at that output is recorded.

Try using the button above that: (USB/2-Trk) To Phones. You should now be able to here both the music and your voice in the headphones but only your voice signal will go to the Main output to Audacity.

See if that helps,
UncaBee

Thanks for pointing me out. I did try the button above “to phone” but there will only be my voice and there is not backing track coming out of the headphone.
Not sure what else to do. I also tried installing the ASIO all driver but the result was same.

Unfortunaly, my work around was to install Tracktion 4 which came with the q502USB mixer.
I am not sure about this but well I can record now. lol

If there is a solution with the audacity that would be great though.
Thanks again!

Have you still got Transport > Overdub enabled in Audacity?

Audacity does not ship with ASIO support due to licensing issues - you have to build Audacity yourself to enable ASIO support.


Gale

Thanks for your input.
Yes, I have the overdub enabled and tested. No luck.
BEHRINGER_2902_X64_2.8.40.zip downloaded from http://www.behringerdownload.de/_software/BEHRINGER_2902_X64_2.8.40.zip
I was told to use this one but no luck.

I am thinking I try the BEHRINGER UCA222 which I bought it awhile back, but haven’t had chance to test it yet.

Do I presume you can’t engage both “To Phones” and “To Main Mix”?

Have you tried recording from the line outs? You could try http://forum.behringer.com/forumdisplay.php?17-Audio-Recording though that does not seem a very active forum.

The UCA 222 should let you monitor playback and your voice - it has a switch expressly designed to do that.


Gale

I have the very same problem and have not found it answered anywhere… could somebody please assist?

Jess, in broad terms the answer is in numerous posts in this Forum - turn on Transport > Overdub, choose the mic you are recording from as recording device in Device Toolbar and wear headphones.

I’m betting your version of Audacity, version of Windows and your recording equipment aren’t all as you cite in your quote. So if you need more help, please give us your actual information, then we’ll move this to a new topic specific to your exact scenario.


Gale

I am new to Audacity. I have the same issue. I cannot record karaoke vocal as music will be recording in my vocal track. Pls can someone help me to set up the Audacity and my sound interface Yamaha MG12XU