Help needed: Can't open .caf files any more?[WORKAROUND]


I do counseling sessions from time to time that I record on my iPad as .caf files. Normally, I open the file in Audacity, to clean the background noise, amplify the sound and then export it to mp3 and give it to my clients.

Today, when I tried it, Audacity crashes when I try to open the .caf file. I tried uninstalling 2.0 and going back to 1.3 but the same thing happened. I then thought that it might have something to do with the .caf file itself and tried to play it in Quicktime, which did not give any problems. Lastly, I tried to open a .caf file that I had previously converted to mp3 using Audacity and once again the application crashed.

I am hoping someone can help me shed some light on what’s going on.

I am running Mountain Lion 10.8.3 on a 27" late 2012 iMac. I get the same problem with Audacity on my MacBook Pro that is also running Mountain Lion 10.8.3.

Thanks for any help :slight_smile:,


iMovie sound files.
Audacity freezes or vanishes?

If the files open in QuickTime, chances they will also open in iTunes. If they do, the desperation method is convert to WAV in iTunes and use that in Audacity.

There is also this MP3 converter although you should not be using MP3 for production, only delivery.

And lastly, I think it’s still possible to do this in Quicktime 7 Pro (not QuickTime X), but that’s a little far afield.

It’s a little hard to believe that .caf files suddenly stopped opening in two completely different Audacity programs – Same Audacity, two machines. Audacity won’t open very much by itself, so you almost always have to load extra software. FFMpeg is the one usually associated with exotic, modern formats. Is FFMpeg loaded on both Audacitys?

Do you still have a much older .CAF file you can use for testing – a file that used to work?

Can you create a very tiny .caf file and post it here on the forum?

Or alternately, post it Somewhere Else that we can see? If it’s under 20MB, I can post it on my web site. Private Message me.



Thanks for your reply and suggestions. I know there are other ways to convert the .caf files and this time I just used a free online converter. However, what bugs me is that something is not working that used to work and I can’t figure out what it is.

I have an old file that I know I have converted back in December using Audacity on my MacBook Pro. Now I can’t import or open it on either computer.

I also tried to make a small recording. It’s called test.caf. When trying to open it in Audacity the program crashes as was the case with the other files. I have pasted the error report into a Word document and PM’ed it to you along with the test.caf file itself.

I have both FFMpeg and Lame installed properly, so I don’t think that should be a problem but you never know.

Hope you are able to help figure out what’s going on…



I am too new to the forum to be allowed to PM but a zipped version of the test .caf file and the error report generated when trying to open it are attached to this post.

Thanks for your help.

Thor (335 KB)
Audacity_error_report.txt (37.2 KB)

Nope. Crashes for me, too. It’s instructive that if you right-click (control-click) the sound file > Open With > Other > Audacity (Application) > “Audacity” is gray. So the system knows this is not a compatible combination, even with the FFMpeg software installed.

Do you have your iPad and/or either/both of the other machines set to automatically update software?

Audacity 2.0.3
Mac OS-X 10.6.8

You have an impossible combination. If I was walking in from the car park cold and never saw you before, I’d say this was normal. What you had before is broken. Unlikely as it seems, this does happen. A quirk of the software allows something desirable to happen and then when somebody fixes the quirk, every body’s show drops dead.

This is what QuickTime 7 thinks is in that file (pix). I’m out of ideas. Koz
Screen shot 2013-04-17 at 4.17.27 PM.png

If I open the file as “Raw Data,” I get a four second white noise “show.”



I do agree that it seems weird that it used to work but no longer does. I just tried on a Windows machine with the result that Audacity says that it does not recognize the .caf format, so that seems to be the reason. I wonder how come it did so before.

I think I’ll go with the caf to wav conversion first and then work with that in Audacity.

Thanks for the help :slight_smile:.


iTunes won’t open CAF files containing Apple Lossless even on Mac.

The reason Audacity is crashing is because the FFmpeg latest version for Audacity that you have (0.6.2) is crashing trying to import the file. That version of FFmpeg can import 16-bit Apple Lossless, but not inside a CAF container.

The reason you could import the file before is that either you had the previous FFmpeg 0.5, which doesn’t attempt to open the file, or you did not have any FFmpeg installed. In those cases, Audacity’s QuickTime importer (which can open the file) gets a chance to open it. This importer is Mac only, so this CAF file is unimportable on Windows.

Unfortunately you cannot tell Audacity to use QuickTime for the .CAF file in the Open or Import dialogues because the file support associations say Audacity cannot open the file with QuickTime (even though it can do so).

To open the file in Audacity you have two choices. Get the older “FFmpeg (2009/07/29/OSX DMG)” from and point Audacity to that version in the Libraries Preferences.

Or keep the current FFmpeg and tell Audacity in the Extended Import Preferences to try the QuickTime importer first for CAF files. To do that, press “Add new rule” and type:


in the text box under “File extensions”.

Then in the “Importer order” list, drag “QuickTime files” to the top of the list.

Now, uncheck the box “Attempt to use filter in OpenFile…”. This ensures QuickTime will always be tried first, whatever you have the file filter set to when opening or importing files. Finally, click OK.



Thanks so much for the explanation. I used the second suggestion as I prefer to have the latest FFMpeg version and it worked like a charm :slight_smile: