Help. Little tics around 6000-8000Hz. Not mouth noises

Can I move this post to the audiobooks area please? I might get more help. These clicks seem tiny but they’re really significant in a audio book!

I’ve moved it, but it’s usually the same half dozen people that answer questions.

How long were you recording “nothing” for? If only a few seconds, try it for a few minutes.
Do NOT turn down the recording level when recording “nothing”, leave everything exactly as it is when you are recording your voice.

What settings are you using the Device Toolbar?

I left it running for four minutes and no clicks. Normal settings etc… Device toolbar as below.
Screenshot from 2021-03-04 22-10-16.png
Many thanks


Do you have a portable radio? If so, repeat the test with the addition of the radio playing near the microphone.

The next test after that is to replace the radio with you talking

Just tried that. Ran it for a minute by the radio, both a woman and man presenter spoke. No clicks. However, the waveform is very different. The whole thing is much more noisy. I did a noise reduction to see if that allowed some clicks to appear but it didn’t.

Now try again with you speaking instead of the radio. Do to recordings, one where you speak any old nonsense but concentrating on not moving while you speak, and one where you relax and do a “normal” voice recording.

Hmmmm well if you insist! But when I record I don’t move; I’m aware any motion can be picked up so I get comfortable, stay still and go for it.

What’s interesting to me is that the frequency (how often, not Hz) of the occurrences appears to increase during the recording. I really think this is a processing issue of some sort. I appreciate that gives no explanation of the radio result. UNLESS the radio audio is easier to process? I know too little about the type of processing which goes on during a recording to speculate.



You know all there is to know about that :wink: - there is no processing during recording.
The sound card converts analog to digital, and Audacity writes the digital data to disk, and that’s about it.

Please do.

Rightyho, so I did a recording whilst sitting like statue throughout. The clicks are there as before :frowning: Also, they definitely occur more often as the recording proceeds.

I don’t really understand what you mean by there not being any processing. Doesn’t converting analogue to digital count as processing? Or even the writing of data to RAM or a drive? Just the conversion needs memory and CPU right? There is a length of data required to convert the signal to requisite resolution. Or am I misunderstanding the definition of processing?

Are there any settings on the laptop or audacity I can fiddle with to try to reduce the problem? Starting to panic a bit as the weekend is the only time I get to do recording!

My sister has a similar setup with linux mint and audacity. Different laptop is all, and she doesn’t get the clicks!



I mean the data isn’t modified by a process.
I guess that the conversion from analog to digital could be called “processing”, but once the data is received by Audacity it is a stream of numbers that are written to disk. Audacity doesn’t care what the numbers are, it just writes what it receives.

How soon during the recording do they start?

Do you use a “pop shield”? (One of these: Pop Shields: Why You Need Them)

Yes I use a pop shield. And the clicks occur in between speech, when I am sitting there doing nothing. First one is a few seconds in and is during speech. Now I know what I’m looking for, I can find them within speech too. Here are two waveform examples, one when the click is between speech, and one during. It’s seriously annoying, if it was a work I could use Matlab to code a match filter and find it and remove it! That would be a fair bit of time developing though and time is what I don’t have! Perhaps there is a plugin?

During quiet:
Click in DC trend.png
During speech:
Thanks again for your help


You’ve got me beat on the cause of the clicks.

They can be repaired effectively with the “Repair” effect and / or “Spectral Delete”, though it would be very time consuming.

There’s also this “de-clicker” effect that may speed up the process considerably:
The only instruction for that effect are in that topic. It is a “Nyquist plug-in” and installation instructions are here:

Sigh, thanks for trying. There MUST be a cause though. I refuse to believe this isn’t fixable!


I wonder if this is an USB artifact. I would be tempted to try interfacing your microphone to Audacity via JACK. Yes, I know it’s another layer of audio management but at least it’s going through a chain optimised for audio capture from USB devices.


Do I buy a usb to jack adapter?

You could try bypassing PulseAudio.

“Pulse” is the default sound system for most Desktop Linux distros. It provides a multi-client audio server layer between applications and the ALSA drivers.

You can tell Audacity to record directly from the ALSA device driver (bypassing Pulse) by selecting the “hw” option that corresponds with your USB mic as the “recording device” in the Device Toolbar.

Hmm… And what happens when you try recording on each other’s equipment?

And what happens when you try recording on each other’s equipment?

What he said.

You could try bypassing PulseAudio.

You could try bypassing the computer.

Now on sale at Sweetwater Audio.

Screen Shot 2021-03-07 at 06.42.02.png
That, pretty much as you see it is how I recorded my technically perfect ACX test submission. People have posted on the forum using Zooms H1 through H6. Granted you still have to buy the memory chip and batteries, but since it has nothing to do with the computer, the sound is perfect.

I believe you can leave the USB cable connected and not have to use the on-board batteries. You can also use it hot as a computer-connected microphone, but I wouldn’t do that at gunpoint.

I’m down for a 9 hours audiobook!

You can troubleshoot your machine while you’re recording your audiobook. If you find out what’s causing this, post back. Nobody has ever solved this.


The accessory package comes with a wall power supply.

Screen Shot 2021-03-07 at 07.15.45.png
Mine came with no memory chip and I contacted the company and complained loudly about that. “The recorder comes out of the box unusable!!” I know this unit used to come with the smallest-possible memory chip to get you going, but the later ones don’t. This wasn’t a big deal for me since I live in Los Angeles and I’m two miles from a store that stocks chips, and Sweetwater did offer to send a chip, but if you live in Middle-Of-Nowhere, this could be a problem.

I told them their advertising needed to be very clear about this.


From memory, one paper towel roll wasn’t high enough, so I used three bathroom rolls instead. You can wear your engineering hat for a minute. The rolls put the microphone at appropriate height, they’re acoustically dead and they don’t transfer vibration from the desk.

I also used oblique positioning (B), not straight-on.

That helped with the signal to noise and greatly reduces P-Popping.

The recorder produces stereo—two channel—and I mixed it down to mono for submission. That adds the voice volumes and reduces random background noise as the square-root of the doobly-do.

A separate recorder also gave me an automatic hardware backup for the performance.