Help Installing QM Plugin to 2.1.2

I’ve been battling this for several days off and on.

I’ve installed Audacity 2.1.2 on Windows 10 64 bit.

Then to install QM Vamp Module, I downloaded the 32 bit version of QM plugin. I put the files in C:\Program Files (x86)\Vamp Plugins. For the record I copied three files: qm-vamp-plugins.dll, and qm-vamp-plugins.n3 to that folder.

I started Audacity and attempted to Add/Remove Plugin and I got a crash with FFmpeg errors.

So I sorted through installing FFmpeg and LAME. I opened preferences and made sure both were located and I included the FFmpeg directory in the path as the first entry. However, I still can not select Add/Remove Plugin without the system immediately crashing. Can someone tell me how to get past this last issue?

Here is the current log file… If someone needs the whole dump file, please let me know.
14:50:38: Audacity 2.1.2
14:50:38: Trying to load FFmpeg libraries…
14:50:38: mLibAVFormatPath (‘C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll’) is not empty. Loading from it.
14:50:38: Looking up PATH environment variable…
14:50:38: PATH = ‘C:\Program Files (x86)\FFmpeg for Audacity;C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\AMD\ATI.ACE\Core-Static;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Common Files\Intuit\QBPOSSDKRuntime;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit;C:\Program Files\Microsoft SQL Server\110\Tools\Binn;C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0;C:\Program Files\Microsoft SQL Server\120\Tools\Binn;C:\Program Files (x86)\RDM Corporation\RDM Appweb\bin’
14:50:38: Checking that ‘C:\Program Files (x86)\FFmpeg for Audacity’ is in PATH…
14:50:38: FFmpeg directory is in PATH.
14:50:38: Checking for monolithic avformat from ‘C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll’.
14:50:38: Error: Couldn’t find symbol ‘avutil_version’ in a dynamic library (error 127: the specified procedure could not be found.)
14:50:38: Error: Couldn’t find symbol ‘avcodec_version’ in a dynamic library (error 127: the specified procedure could not be found.)
14:50:38: avformat not monolithic
14:50:38: Loading avutil from ‘avutil-52.dll’.
14:50:38: Loading avcodec from ‘avcodec-55.dll’.
14:50:38: Loading avformat from ‘C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll’.
14:50:38: Actual avutil path C:\Program Files (x86)\FFmpeg for Audacity\avutil-52.dll
14:50:38: Actual avcodec path C:\Program Files (x86)\FFmpeg for Audacity\avcodec-55.dll
14:50:38: Actual avformat path C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll
14:50:38: Importing symbols…
14:50:38: All symbols loaded successfully. Initializing the library.
14:50:38: Retrieving FFmpeg library version numbers:
14:50:38: AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
14:50:38: AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
14:50:38: AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
14:50:38: FFmpeg libraries loaded successfully.

When Audacity launches, it looks to see if it can find a version of FFMpeg that it can use. Audacity usually has to search through a number of options before it can find a configuration that works. The FFMpeg related “errors” that you see relate to failed attempts to load FFMpeg. When an attempt fails, Audacity moves onto the next option until either it successfully loads FFMpeg, or all attempts have failed.

This is the important line:

14:50:38: FFmpeg libraries loaded successfully.

It means that Audacity managed to successfully find a version of FFMpeg that it can use, and has loaded it.
This is not related to your issue with VAMP plug-ins.

I’m not on Windows so I can’t try out the exact same plug-ins, but there is some information in the Audacity manual that may help:

If you still have problems with these plug-ins, please post the address of where you downloaded the plug-ins from so that someone on Windows can check it out.

The 1.7.1 Queen Mary plugins crash Audacity, as it says in the 2.1.2 Release Notes. Follow the instructions in that link to install the older 1.7 plugins instead.


OMG I have lost so much time to this issue. None of the articles, videos, etc. worked for me. I had this same issue on Windows 7 with v2.1.1 and I don’t remember how I fixed it.

Ultimately I added the following entries to the EXISTING Windows “Path” environmental variable:
C:\Program Files (x86)\Audacity\Plugins
C:\Program Files (x86)\VAMP Plugins

Basically append this to the existing string of the Path variable, remove the quotations:
“;C:\Program Files (x86)\Audacity\Plugins;C:\Program Files (x86)\VAMP Plugins”

and finally after HOURS it works.

What doesn’t work (for me):
Adding VAMP_PATH environmental variable with path to VAMP plugins. As soon as I add this Audacity’s plugin interface won’t load period and it dumps a crash report. Once I delete this environmental variable it works again, but then of course I can’t load the QM plugins.

As previously explained, the 1.7.1 Queen Mary plugins crash Audacity, but the older 1.7 plugins do not.

If the environment variable points to the new plugins, then Audacity will crash.

Online videos are often wrong. There should be no need to look at anything other than