HELP -- CPU not reading input

So, my Audacity is installed and functioning, all of my internal levels are dialed-up adequately, and I don’t understand why Aud. is not reading any input. I’ve tried a couple of different mics in both the mic input jack, as well as adapted into the dual (red/white) audio input jack. So, I’ve tried both mic and line inputs. It appears that Aud. is functiong fine. I’ve read the FAQs, but still stumped.

Thanks for any advice.

I presume you are on Windows?
Perhaps Vista?

You need to find the sound card’s mixer and set the correct recording input and recording level. You will probably find it via a loudspeaker icon near the system Time/date. If not, look in the Windows Control Panel (sounds and audio devices).

Windows XP. Have done that–everything looks good with the settings.

Audacity version?
Your settings in Audacity Preferences?

I’ve been through that field several times–all the levels are up, and mic/line input is selected. But I see no options for any Audacity selections…?

Edit menu > Preferences > Audio I/O (Audacity 1.2.x)
Edit menu > Preferences > Devices (Audacity 1.3.x)

What does it say?

Help menu > About Audacity > version?

Sorry, but without more information there is little anyone can do or say to help you.

You are helping Steve! I hadn’t checked that field–it was set for something other than mic/line input. The output choices are Microsoft sound mapper and Realtek HD rear…but the output seems to be working, as I can hear the speakers activated upon “play.”

I connected a tape deck, but still nothing.

Go here and scroll down the page to where it says “On XP or earlier”
http://wiki.audacityteam.org/index.php?title=Mixer_Toolbar_Issues#Using_the_Control_Panel

In the “Audio” tab of the “Sounds and Audio devices” window, what do you have listed in the three boxes?

Yeah, I’ve been through all of my volume settings–they’re all up and not muted, and inputs are selected to “mic/line.”

here’s the info for Windows:

On Windows XP systems with RealTek audio hardware and up to date drivers, Audacity may not show the mixer drop down control or it may be disabled. Recording while playing a song records silence, regardless of what is chosen under the Audacity I/O preferences.

This can be remedied as follows:

  • Go to the control panel and launch the “RealTek HD Sound Effect Manager”. Access the Mixer Toolbox (via the wrench icon). Check the “Enabled recording multi-streaming” option (that is the key). This will create a new sound device (and also lock up anything playing music at that time, so close them first). You want to see a volume for “Stereo Mix” that should not be disabled. If it is disabled (red cross over its volume icon), enabled it. Nothing will change in Audacity, but you will now be able to record what is being played!

  • In general remember that you can also go To Start, Accessories, Entertainment, Volume Control. Use the Options to access all the settings or flip between recording and playing. Make sure nothing you need is muted or has its volume set to zero. Do note that if you have a microphone plugged in, you may want to mute it to record something playing from the internet for example, just dont forget about the fact that you muted it here. These settings can usually also be accessed via the “RealTek HD Audio Manager” which can be set to appear in the system tray.

I know what it says in the Audacity wiki. I don’t yet know what is set wrong on your computer.

What I’m asking is what you have as the 3 default devices in the Audio" tab of the “Sounds and Audio devices” window.

The “Sounds and Audio devices” window will look something like this:

You still have not said which version of Audacity you are using.

Try recording with Windows Sound Recorder. Are you able to record anything with that?

Sorry, I’m sure it’s frustrating trying to help someone who is not very computer savvy. If I knew the answers to these questions readily, I probably wouldn’t be asking them… :blush:

I have no idea what version of Aud I’m using–it doesn’t say anything other than “Audacity.”

The only place I find this field is through my CONTROL PANEL - sounds and audio devices - audio: the three boxes are: Sound Playback - RealTek; Sound Recording - Line in/Mic in; MIDI Music playback - Microsoft GS wavetable SW Synth

Open Audacity. Click on the “Help” menu and select “About Audacity…”


Yes, that’s exactly right.

You will notice that this window is divided into 3 sections; “Playback”, “Recording” and “Midi”.
In the “Recording” section, click on the “Volume” button. This should open up the “Recording Control” window.

In the “Recording Control” window, click on “Options” and select “Properties”. This will open up the recording Properties window. It should look something like this:
recording-properties.png
It will look a bit different on your machine and I would like you to describe what it looks like on your computer.
In the box where mine says “Intel(r) Integrated Audio”, what does it say on yours?

Where I have the list in the big text box at the bottom, you will see that I have all of the items ticked. What items are in that list on your computer? Which ones are ticked?

Under “Recording Control: Properties”:

Recording Control; CD Player; Line In 1 or 2; Microphone; Stereo Mix…all of them are selected (checked) except for the last – Stereo Mix.

At the top under “Mixer Device,” I’m given three options: Line In/Mic In (selected); RealTek HD Audio Rear Output, or; RealTek HD Digital Input

FYI, I appreciate all of your help, Steve. I’m writing for a professional recording and touring band, and I really need to get this thing up and running. Regards, Randal

Select (check) “Stereo Mix” as well (so that they all have ticks) and Click the “OK” button.

I’ll have to leave this as well - it’s late here and I’m working 14 hours tomorrow. I’ll try and get back to you on Friday. If you make any progress in the mean time, make a post and let me know.

catch you later,
Steve

Any other ideas, Steve?

OK, let’s do a recap of where we are up to:

  1. You have Windows XP
  2. You have installed Audacity - we still don’t know what version - Open Audacity. Click on the “Help” menu and select “About Audacity…” What version does it say that you have?
  3. You have a RealTek HD sound card (probably built into the motherboard).
  4. You have a laptop/desktop PC - is it a laptop? is it a desktop computer?
  5. Are you able to play sounds in Audacity? (Import an audio file and press play).
  6. You are able to find and open the “Sounds and Audio devices” window - does it look similar to this?

If you click on the “Volume” button on the “Sound Recording” section of the “Sounds and Audio devices” window, it should open up a “Mixer” window. Does it?

I’ve got it. A friend came over and searched online support for Windows…he manipulated some other field for the audio operating system, but I missed what that was, and found another mic input on the back of the computer–which I hadn’t seen. For some reason, the inputs on the front aren’t enabled–which I 'd suspected, but I didn’t see the input on the back.

After downloading the “LAME” converter software, I’m in business.

Thanks for all your help, Steve.

Randal

Cool :smiley:

I think we were getting there slowly, but often it’s easier if someone can show you.