HELP! can't record multiple tracks

Hey there. I must say I am more than a little disappointed in this forum. I just posted a problem (I’ll quote it below) and after three days and over 100 reads, not one single person could offer any advice or even encouragement. No one could direct me to a source of help. No requests for more information. Not even a " read the manual, noob. " I started using Audacity because it seemed like a shallower learning curve than some other software. But I guess I’m back to the other guys’ programs.

I’ll try one more time. Just to give the benefit of the doubt.

“Hi guys. I’m new to Audacity. Using Windows 10 on a Dell Inspiron 790 and Audacity 2.3.3
I am following the manual for recording multiple tracks, and get the first track down fine. Whether it is imported drum track from Acoustica Beatcraft, or my own guitar, the initial recording works fine. I can play it back, and hear myself playing along as well. The record meter even registers activity, as expected.
However, when I hit record to create the second track, I get nothing. I am set up to record straight to new mono track, so it’s not an append issue.
I hit record, a new mono track appears, the red triangle on the timeline sits at 0, (sorry I don’t know the technical term) but I can’t hear the previously recorded track, and my new track doesn’t record. I can hear myself playing, but nothing is recording. Overdub is checked, software playthrough is unchecked, as per the manual instructions.
The best way I can describe it is this, if this were an analog tape recorder, the pause button would be stuck. The lights are all on, the tape record heads are in contact with the tape, but nothing is rolling.
Please help!”

I hope some kind soul on the forum will read this and point me toward a solution.

Occasionally posts fall through the cracks. The volunteers that provide support for Audacity aim to reply to all posts within 24 hours. Most posts receive replies much quicker than that. The number of “reads” can be misleading as the forum is constantly being trawled by various kinds of “bots” (such as search engines).

What recording device are you using? If you’re recording yourself playing an instrument, what is the instrument and how is it connected to your computer?

thanks so much for your reply, Steve. I was a little bummed, as any other forums I’ve posted on get replies within just a few hours. Apologies to the Audacity forum collective, as it were. It seems I was worried for nothing.

I am using the Roland Rubix 22 USB interface to record electric guitar.

The Rubix has two inputs - both combination 1/4 inch and XLR. Channel 1L has a Hi-z switch, and channel 2R has 48v switch. Obviously to optimize line-in, instrument, dynamic and condenser mic signals. I use 1L for electric guitar - a Stratocaster with standard passive pickups. I have also successfully imported a drum track from Beatcraft. The guitar track and drum track are two different Audacity files.

I know on another recording program, I needed to assign each of the Rubix’ inputs to its own track, or select a default input with option to change it for each new track. I don’t see that option on Audacity, so I assume all is well. And, like I said, I can easily record my first track this way, no problem.

What do I need to do to get multi-tracking to work?

You need to set the Roland Rubix as the recording and playback device in the “Device Toolbar”.

The “host” setting will probably need to be set to “MME”.

Go into the Windows Sound control panel, and ensure that the Roland Rubix is set to the same sample rate (preferably 44100) in both the “Recording” tab and the “Playback” tab.

OMG Yes!! I knew it was something simple like that. Everything you suggested was already set that way, except the playback sample rate on my computer was 48k, not 44.1k. Fixed that, and laid down a couple tracks to test it. Awesome.

Thanks for your help Steve. I will be back with more questions should they arise.


Hi im trying to record my Yamaha modx7 onto audacity im using a m audio duo interface and my acer aspire 3 laptop, im able to record the 1st track but im unable to record a second track ive tried to change my input biterate is 41000 but my output bitrate is 48000 I’ve changed the output bitrate to 41000 but everytime I go back into audacity and press record on the second track it still doesn’t work,I then go back to the settings and the output has changed back to 48000,ive tried everything to sort this problem out but no success! Please help.

Audio CD sound standard is 44100, not 41000.


Yea sorry I ment 44100

So does it work when you set Audacity’s project rate to 48000 ?

unfortunately no my laptop keeps changing the settings back to default every time I press record. I’ve applied the setting 44100 but when i go into audacity and press record on my second track it doesn’t and when i go into the audio settings again the output has resorted back to 48000,ive tried everything but cant lay down a second track.i can use audacity absolutely fine when not using my m audio interface and just using the laptop!

which setting ?

So try setting the Audacity Project rate in the lower left-hand corner to 48000 before you start recording anything.

Just a note here. As above, your system has to record and play absolutely perfectly before you start overdubbing. People make an ordinary recording and assume everything is perfect, then fall flat when the playback side fails. Even worse when it’s not obvious that’s what happened.

It’s also a good idea that the Record and Play system be the same device. No fair recording from your USB microphone and listening on your Wireless earbuds. That will almost certainly fail for several reasons.

Never do production with wireless equipment or on External, Network, or Cloud Drives.