headphone mic not working anymore [SOLVED]

I have an MSI laptop running Win10. When I noticed it was not working, I upgraded to the latest version 2.1.2, and it made no difference. I used the .exe installer with the help files.

I have a wireless headphone with a mic on it from Logitech. It has been working for me fine. Today, when I hit record, I got a recording of silence. I can blow on the mic and hear that in my headphones, and I can hear playback in my phones. The mic is still selected in the recording device window, just like before. I’ve turned the recording volume all the way up. The monitor window shows nothing.

If I change to the laptop’s mic, that works. But I cannot hear what I’m recording in my headphones, as I did before. If I change the preference to overdub, then it starts playing other tracks when I hit record. That’s not what I want, so I turned that back off. If I select software playthru, which I don’t think I had on before, then I can hear myself, but there seems to be an echo. The echo is not in the recording. But I really want to use the headphone mic, because it is so much closer to my mouth, I don’t have to crank the volume so high, and I don’t get so much “air” sound.

Take a look in the Windows Sound Control Panel in the “Recording” settings. Do you see the green meter responding to your talking?

Try “Rescan audio devices” (near the bottom of the Transport menu, then check in the device toolbar that the correct mic is selected.

Yes, I see a green meter responding to my voice in Sound on the Recording Tab for my Logitech headset microphone. I rescanned devices in the transport menu of Audacity, and verified that my logitech headset microphone was selected in the device toolbar. No joy. I can hear the the mic in my headphones, but the meter doesn’t indicate anything in the recording level meter.

When you have selected the correct mic in Device Toolbar, turn up the input level up in Mixer Toolbar:


That slider seems to make no difference.

What happens if you record with the Logitech mic chosen as recording device in Audacity’s Device Toolbar, and the Mixer Toolbar input slider turned up, then Stop, Effect > Amplify… and OK? Do you then see a flat line, or hear only loud noise, or hear your recording with a lot of noise in the background?

What happens if you record with some other application while the mic is default device on the Recording tab of Windows Sound? For example, click Windows Start, type “recorder” (without quotes) then press ENTER on your keyboard. Click or tap the microphone icon to start recording, and click or tap the Stop button when you’re done.


That did the trick for me. Apparently there is a volume control knob on my left headphone, which had gotten spun down to zero. When I got it turned back up, all was as it should always have been.

Thanks so much for sticking with me.