Having trouble with Pyle 8-channel mixer for podcasting


Sometimes I get the settings right with this, then sometimes it seems all over the place. If I could ever
find an acceptable setting, I would write them down. I have 3.0,2 Audacity, with Windows 10. I have two
JBL monitors plugged into my computer, a USB from the USB port on my mixer connected to my USB port
on my computer, and my Rode mic plugged into the first mic input. I can’t seem to get any reverb at all
and the only way I can get headphones is by plugging them with a 1/8" into my speakers. I have controls
on my mixer for this, but I don’t know how to set it up.

Also, my settings across the top of Audacity is:
(1) MME (2) Microphone Realtek Real Definition (3) Stereo Recording Channel and (4) Speakers Headphone (Realtek).

Does anybody have any suggestions for a better setup?

Larry Cockerham
P.S. Sometimes I think it would be easier to go back to my 2-channel Behringer mixer.

Only some multi-track audio interfaces (mixers) are compatible with Audacity
https ://manual.audacityteam.org/man/multi_channel_recording.html

Audcaity’s (free) competitor OCENaudio can work with the industry-standard ASIO drivers, (unlike Audacity),
so is more widely compatible with hardware.

I think it would be easier to go back to my 2-channel Behringer mixer.

Bringing you straight into my rule of: “If you have something working, hold onto it with white knuckles.”

Count the number of forum posters who did machine, OS, or software “upgrades” and their podcast or show hasn’t been seen since.

Describe the podcast. I was able to do a good quality, simple show with a Skype interview, local microphone, and music playback using a simple sound mixer and two computers. One machine was running Audacity to record the mixed show and I used the machine’s internal music system to play music. The second machine ran Skype. It would have been a dead simple task to expand to two or more hosts here in Los Angeles, without very much more hardware. This is a close cousin to how the broadcasters do it.

People go off the deep end the instant they try to do do too many different jobs and tightly integrate the computer to the mixer. That’s not fun as you’re finding. Computers have one stereo record system and one stereo playback system. Full Stop. The instant you approach with a job and a laundry list of different tasks and pathways, this could call for very strong coffee.

There is also the very real possibility that what you were doing with the Behringer was broken. What you have now is working normally. That happens many more times than you think. There was one poster who, against all odds, managed to pull off his “Movie Commentary” podcast repeatedly and reliably. Nobody else on earth could replicate his setup, and many thousands tried.

So describe the show.


Is this your mixer?: https://www.amazon.com/Pyle-Interface-Bluetooth-Connection-PMXU83BT/dp/B0719BC5FS?th=1

It looks as though you are trying to record and playback from your PC’s internal microphone. According to user reports on that Amazon site:

The device comes up as “JieLi BR17” in the sound settings.

So, select “JieLi BR17.” in your device window. That could account for both your microphone and headphone issue.

according to at least one customer review:

The effect on this board, (there’s only ONE!), is a simple, ANALOG delay effect. Even the mixer has the word, ‘MulitEffects’ right on it! JUST NOPE!..don’t expect to get any REVERB effect with it.

Yes, this is a picture of my Pyle 8-channel mixer. I will try to adjust the settings. I had
reverb at one time. Probably I changed the settings up top of Audacity. I have two
JBL speakers hooked into my headphone jack on the computer and the USB cord
hooked into my USB input on my computer. My Rode mic is in input one.

Okay, I think I found some of my problem. Now my reverb is working. It has to do when I first plug my speakers into the laptop, you have to choose the setting. When I chose mic plus headphones, my reverb came on. But I have to switch the USP Player now from PC to 00 back and forth to record and play. This gives me a great sound so far as I can tell. I usually plug my headphones directly into one of my speaker connections. I’m still not sure how to get back to the JieLi BR17 setting you mentioned. I saw it at one time.

Try Transport > Rescan audio devices.