Having a little trouble using my new iRig microphone

I recently bought an iRig microphone for my guitar, but it hasn’t been working perfectly with audacity. It only records when I have Software Playthrough unchecked, and I can only listen to what I recorded when I have Software Playthrough unchecked. Otherwise, I get a message that says “error while opening sound device please check the recording device settings and project sample rate.” This makes recording overlapping parts impossible. Is there a fix to this?

Is it this http://www.ikmultimedia.com/products/irigmic/?

To begin with, it requires a four pole TRRS audio input/output port on your computer. Do you have that? Is it an input meant for connecting a headset with audio that goes both in and out?

You are supposed to monitor in real time by connecting headphones to the other side of the mic’s connector plug. So you should not have software playthrough on at all because it will create an echo. I don’t know if it’s supposed to receive playback from the computer. You can record with one earpiece off your ear. Even some professionals record like that.

Use Transport > Overdub to hear an existing track and record over it.

Regarding the error opening device, it sounds as if you might be choosing Windows WASAPI host in Device Toolbar. Try MME instead. Use 44100 Hz bottom left of Audacity.

Also please post the entire contents of Help > Audio Device Info… top right of Audacity. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

Also tell us what version of Audacity you have (Help > About Audacity… ).


Gale