Have I broken something? :p

In the course of editing, I noticed that suddenly the blue line in the middle is thicker in Waveform view. I have no idea how it happened and can’t hear anything differently during playback. The same line is still thin in Waveform (dB) view. I don’t know what on earth I’ve done.
Screenshot_11.jpg
Screenshot_12.jpg

What kind of computer, which operating system, which numbered version of Audacity?

You can’t see it, but I have the puzzled cocker spaniel look. Waveform dB allows you to view all the loudness values available (96dB??), but in my opinion, it’s a little awkward to edit because of Too Much Information. Much easier to edit in Waveform view even though it only shows the loudest 25dB of the show.

This is the exact opposite of what you have. Waveform view is apparently showing more sound than dB view.

Your Waveform view in my opinion is realistic. It’s perfectly understandable to have very low volume trash in the silent portions of the show. Happens to everybody.

Your Waveform dB view is almost impossible. Nobody shoots live sound with a -96dB (dead flat) noise level. You’re sure these two views are just one sound clip switched between the two?

Drag-select a portion of that clip featuring both the silent and sound portions (don’t go much over about ten seconds). Export Selected > WAV (Microsoft). Post it here on the forum. Scroll down from one of these text windows > Upload Attachment > Browse…

Koz

Aw, puzzled Cocker Spaniel looks are adorable. :smiley:

I have an IBM ThinkPad T520, Windows 7 Ultimate and I’m using what I believe is the latest version of Audacity - 2.1.2

I’m attaching four files - two are of silence areas in the files (both original and working copy/cleaned up version) and two include a small bit of sound in roughly the same area in the recording. I imported the WAV files into Audacity to see what the Waveform looks like, and in that instance, the line in the working copy file (the one with the thicker line) is as it should be - a thin blue line.

This happened out of the blue - and whatever happened affected the entire file, not just the portion I was editing when I first noticed the issue. I wonder if it’s some sort of glitch in the software. This is the strangest thing.



You’re right : there’s something wrong. When I try to amplify a flatline [?] section of the dB waveform of “Silence - Original Copy File” by 50dB, I get a “validation error” …
attemping to amplify dB version by 50dB produces ''Validation error'', [ amplify linear version by 50dB is OK , no error ].png
The same error-message occurs with computer-generated noise below 60dB : the problem is with Audacity [2.1.2], not your audio file.

It depends on the version of Audacity and the settings.
In Audacity 2.1.2 there is a setting in Preferences to set the dB range for the meters - this setting also controls the “default” dB range for the Waveform dB view. The dB range can be changed using shift+mousewheel http://manual.audacityteam.org/man/audio_tracks.html#scale

When in dB view, any signal below the minimum dB range level will be off the scale - that is, it will appear to be absolute flat-line silence.

Unfortunately that is a “peculiarity” of the input validation and is due to rounding errors
The maximum amount of amplification allowed by the Amplify effect is +/- 50 dB.
In your image, the effect is attempting to amplify by +50 dB. The error message says that the range is -110.4820 to -10.4820 dB, (from which we can deduce that the current level is -60.4820 dB. However, due to rounding errors, the “New Peak Amplitude” has been calculated as -10.4818 dB, which is 50.0002 dB above the current level, which is 0.0002 dB out of range. “0.0002” may seem like a large rounding error, but this is a logarithmic scale. The difference between -60.4820 and -60.4818 dB is only -0.00000002 on a linear scale and we are multiplying a very small value by a very large amount.

When in dB view, any signal below the minimum dB range level will be off the scale - that is, it will appear to be absolute flat-line silence.

None of which explains the poster’s apparently displaying quiet work in Waveform view and not dB view. I expect exactly the opposite. Work typically drops off Waveform view when it’s below about -25 to -30. That’s well within the most common dB range values.

I’m not at a good machine to inspect the samples.

Koz

None of the posted audio samples match the waveform images in the original post.
The “linear view” image in the first post looks to have “noise” with a peak level of probably around -40 to -50 dB.
The “Waveform dB” view appears to show flat-line silence at the beginning, but we can’t see the vertical scale.

That’s because it isn’t the same. The first images I posted where when and where I first noticed the thick line in Waveform view (about 8 minutes into the file, after I’d been doing some edits and I switched from Spectrogram view (or dB view) back to Waveform to do a quick playback and all of a sudden, the thick line was there when it hadn’t been before). Then I was asked to provide samples so I went to the beginning of the file and grabbed some speech and silence samples.

The quiet work appears in dB view - in Waveform is where I see the thick line. But like I said, when I import the samples into a new Audacity file, the Waveform lines then show up like a thin blue line, as they should; just not in the (working copy) file where the problem suddenly showed up.

I don’t think it’s anything to worry about.
When Audacity calculates the waveform graphic, it looks at the sample values and then scales them according to the vertical height of the image, rounded to the nearest pixel. On my machine, the waveform changes from a 1 pixel height straight line to 2 pixels high when the peak level hits about -43 dB. If we look closely at the “Screenshot12.jpg” image that you posted, the “silence” is 2 pixels high in places, rather than a 1 pixels high flat line. That says to me that the noise level is probably peaking at about -45 dB, or you have zoomed in a bit vertically (http://manual.audacityteam.org/man/zooming.html#vertical) and the noise level is lower than that.
Screenshot_12.png

So, it occurred to me to try copying the entire track into a new Audacity file, and that seemed to fix the problem. No more thick line. Well, alrighty then …

Thanks for all the responses. If this happens again I’ll know how to deal with it. :stuck_out_tongue: