harmony question

OK, I’m really new to this thing. I’m trying to record vocal harmonies for practicing parts. Let me explain what I want to do - I want to record a melody, then listen to it while recording a harmony or two, then (here’s the tricky part) I would like to be able to listen to any of those parts INDIVIDUALLY without the others. Is that possible? All I’ve been able to do is lay down a melody, then a harmony (which is mixed with the melody), then another (all three mixed together). I need to be able to hear each one individually. Can you help me?

I’ll take this backwards. If you have multiple tracks stacked one over the other (violins, cellos, tubas) you can select Mute or Solo (on the left) and that track will either play by itself, or vanish temporarily.

You need to not be recording the computer’s Mix-Out. That service has the whole world on it and you will keep getting one performance jammed on top of all the others. You do want that service if you’re trying to record Internet Audio. You manage sound pathways in the Windows Control Panels.

Windows Control Panel

I think there’s a wiki having to do with sound multi-layering, but I can’t find it. I know you need to change Audacity preferences to “Play One Track While Recording Another,” and past that, we need to wait for a Real Windows Person to help.


I still can’t get it to work. It seems to be how the tracks are recorded, not the playback. I can click to solo the track I want the hear, and even mute the others. But I still get track one only, tracks 2 & 1 mixed, then all three mixed.

Your goal is to record your voice on one track by itself while you’re listening to others. Then do it again and again. You “told” Windows to record the total of all the computer audios instead of just your microphone. That’s a setting in the Windows panels.

Like I said, what you have is the setting most people use to record YouTube sound into Audacity. You want the opposite of that. I wish there was a Windows person here and/or I could find the instructions for sound-on-sound recording.


If I could find this stuff in a hurry I’d be really valuable…


If you open the Windows Mixer/ Sound card Control Panel, I suspect that you will find that you have the recording source set for recording “Mix”/“Stereo Mix”. This will record all sounds that are playing through your computer, so your individual tracks are not really individual, but also have the sounds of all previously recorded tracks. You need to set the recording source as “Microphone” or “Line in” (according to which you are using).

Maybe I’m not looking in the right place. Here are my current settings…

Control panel > Sounds and Audio Devices > Audio > sound recording > line in/mic in (there are no other options here. If I click on “volume” I see levels for recording, line vol, and mic)

Control panel > Sounds and Audio Devices > Audio > voice > same as above

Control panel > Realtek HD Sound Effects Manager > Mixer > (little wrench thingy) > show volume controls > line volume, microphone, stereo mix

Should I be looking somewhere else?

Oh, and the wrench thingy is under “record.” Above that & to the right I also have selected “line in/mic in” again, no other options.

Hey! I “muted” line volume and stereo mix in Realtek HD > mixer > record and I think its working!!!

Cool :sunglasses: