Hardware/Software Playthrough issue with Blue Yeti USB Mic

My Setup:

OSX 10.14.6
Audacity 2.3.3
Mic: Blue Yeti USB
Monitoring: done via headphone jack on Yeti

I’ve been using Audacity for years and I would monitor input into the Yeti directly via headphones so I can hear myself while recording a voice over track. Prior to upgrading to Audacity 2.3.3, I would just plug in my headphones to the headphone jack on the Yeti and select the Yeti as both the input and output device. Worked great for a long time and I could record and hear myself in the headphones in real time with zero latency (hardware playthrough).

Now, with hardware playthrough no longer an option in Audacity 2.3.3, the only way I can hear myself through the headphones is to turn Software Playthrough on, which results in extreme latency in the headphones and that makes it completely unusable if you want to monitor yourself while doing voice overs.

I’ve turned Overdub on/off and the results are the same.

So far, my only solution has been to revert all the way back to Audacity 2.0.6 and my setup works fine.

Any suggestions on how to get the latency to go disappear and have hardware playthrough in 2.3.3?

Zero latency monitoring should be independent of any software. So long as the mic is powered on, you should be able to hear yourself via the mic’s headphone jack.

“Software Playthrough” in Audacity should be “off” (not selected).
“Overdub” in Audacity should be “on” (selected).

(Mac OS X / macOS has not supported the “hardware playthrough” option since at least 10.0. Audacity continued to support the feature for the benefit of users on old computer’s for about another 4 or 5 years after it was discontinued by Apple).

I think you have something else wrong. Your own voice comes from the Yeti, not the computer. This is from the Yeti instructions.

Screen Shot 2020-04-02 at 7.04.05.png
No software clicking and no latency because your headphone voice comes from the Yeti.

The full blue box on the right has a warning not to use the headphone connection for speakers in internet conferencing because it doesn’t follow the computer sound services. It’s self-contained.

Many microphones work like that. Here’s a G-Track.

I think your software change happened to correspond to some hardware problem.


Under 2.3.3 when recording, the only way I can get audio to come out of the headphones while those headphones are plugged into the Yeti is to have Software Playthrough enabled. I can hear myself fine in the headphones prior to hitting record, but once I hit record, the headphones essentially shut down. There’s no audio at all…not my voice and not any other tracks which I should be hearing if Overdub is turned on. Stop recording and the headphones come right back on. So, it doesn’t matter if overdub is turned off/on the results are the same…no audio at all in the headphones once recording starts (regular playback works fine of course, it’s just while recording that the audio in the headphones dies unless software playthrough is enabled).

I agree that the voice should be coming from the Yeti, but in 2.3.3 it doesn’t appear to be working that way.

2.0.6 doesn’t have this issue at all. I’m continuing to use 2.0.6 but would prefer to update to 2.3.3 as it’s much faster.

I can actually confirm this. I’ve got my headphones plugged directly into my Yeti, and hardware playthrough works just fine until I hit monitor or record, at which point it cuts out.