guitarix_freeverb plugin problem

hello there, i’m having a curious problem with this particular plugin:

i have 2 computers, both xp sp3 and this plugin, wich i like a lot, is working only on one of them.

i´m running audacity 2.0.0 and i also tried with 2.0.3 but i can’t make it work, audacity always crashes with an appcompat error.
i’ve tested it with 2 soundcards with same result. i’m pretty sure that´s a software problem but i have no idea where exactly the problem is.

any idea of what’s going on?

As far as I’m aware Guitarix only runs on Linux

Did you get it from here Google Code Archive - Long-term storage for Google Code Project Hosting. ?

It’s OK for me on Windows 7. Does GVerb (also a LADSPA effect) crash?

You could attach appcompat.txt but there is not a great chance it will help. Please see here for how to attach files: .

My best advice would be to remove all the DLL files from the Audacity “Plug-Ins” folder except guitarix_freeverb. If it does not crash, add other plug-ins one by one until Audacity crashes then you have found the one that conflicts with it. Unfortunately you will have to set the VST rescan in Effects Preferences and restart Audacity after adding each plug-in.

If you want to try it, Audacity has an experimental “Reverb” effect (based on the original Freeverb) in the Nightly Builds. Choose the latest zip file from the top of this list . Quit Audacity, extract the downloaded zip file to any location on your computer then run “audacity.exe” from the folder you extracted to.


thanks for your early answers, i think i’ve located my problem.

debugging on visual studio i found the address that make it crash with an 0xc000001d illegal instruction error:

6d915fc5 fisttp dword ptr [esp+5ch]

looking for fisttp i realized that is an SSE3 instruction not supported by my old P4 northwood, so i guess there is not an easy way to get the plugin working with this CPU.

weirder yet, i’m almost sure that i had it working fine on linux (musix 1.0 distro i guess) with this same cpu, i’ll try this option.

i was wrong thinking about a software problem. :smiley: i’ll also try the new reverb feature, looks great. thanks for your tips. :wink: