Guitar w/Behringer interface.

My computer is a Dell 8700 with 32gig of ram and an i7 processor. I have a Behringer U-Phoria UM2 interface with either 2 instrument inputs or one microphone and one guitar or just one guitar. The Realtek drivers are current and update. The drivers for the UM2 are the ASIO4All and current. I also installed Audacity 2.2.X. By the way I like the new look of 2.2.

What I want to do is be able to play the guitar through the interface (which is USB), through the computer and hear the sound on the computer speakers. Then hopefully I can more fully utilize the capabilities of Audacity. I have played with the various sound settings but cannot seem to get it to work. I can record and the when Audacity plays back I can hear my playing but I want to hear as I play but that only happens when I run the guitar into the computer using the Microphone input without the UM2 interface.

Frankly I am at a loss as to what the problem is, let alone a solution. I would settle for plugging the guitar into the computer using the Mic input and hearing the sound but I haven’t been able to accomplish that either. Anyone got an idea or better yet, a solution? Thank you.

If you select “software playthrough of input”, you should hear the guitar through the computer speakers. Now the bad news software playthrough is inevitably delayed.
software playthrough is inevitably delayed.png

Audacity does not apply effects in real-time. It’s an audio-editor for post-production work.
If you can obtain other software which applies effects in real-time, Audicity can be used to record & edit that performance.

The UM2 is a very nice USB microphone preamp with the option of a secondary channel for “instrument” or guitar.

One setup option is record in Stereo and have the microphone on the left and the guitar on the right.

You can also set it up Mono (the reason I bought it) which gives you the microphone in the middle between left and right and no guitar.

I believe those are the two options.

So you can record in stereo with nothing plugged into the microphone and the microphone knob turned all the way down. Turn up the INST knob.

That will give you a stereo show with a flat-line left and guitar on the right.
Screen Shot 2018-03-09 at 19.03.00.png
Then use the drop-down menu on the left of the track > Split Stereo to Mono.

[X] delete the flat line track.
Screen Shot 2018-03-09 at 19.03.19.png
Audacity doesn’t use ASIO software.

hear the sound on the computer speakers.

Yes, but you probably won’t like it. The computer speakers, unless you mess with the Windows settings and get lucky, will be one computer late and sound like an echo or reverb. That’s why if you’re going to overdub to yourself, you have to listen to yourself and the backing track on the headphone connection of the UM2, not the computer. That connection has zero latency (echo) monitoring.

Since you’re on Windows, you also have to worry about the Windows sound settings. Windows comes out of the box all set up to do chat and conferencing. It automatically applies environment suppression, filtering and echo cancellation to your voice. Those tools all hate music.

This is where to find the adjustments. I’m not on Windows.

So what I would probably do is corral an XLR (3-pin) microphone, set it in front of your speakers, crawl into your headphones, set the system up for over dubbing in Mono and see how that goes.

This is how to set up for overdubbing.

Let us know if you get stuck.


I think I messed a step there. Do you have guitar speakers separate from the computer? That microphone thing is going to pick up your guitar speakers, not the computer speakers. You can’t use the computer speakers for anything until you’re editing later.

If you have your choice of weapons, the Shure SM57 is very highly thought of for instrument recording.
Screen Shot 2018-03-09 at 19.40.19.png