guitar rig 5 dll cannot be detected in audacity effect

hi. i have a simple question. does that basically mean we windows 7 64 bit users cannot record with guitar rig on audacity since audacity only support 32 bit ? please let me know. or is there a way to make it work? thanks

Audacity does not do “real time” effects.

You may be able to use the stand alone version of Guitar Rig and then record it by “recording sounds that are playing on your computer”:

If you have difficulty getting that to work, then it may be better to use Guitar Rig as a VST plug-in. To do that you will need to use a suitable “host” program (not Audacity as Audacity does not support real time effects). A good low cost option is Reaper. There are many other VST host programs to choose from including Cubase and Sonar.

Coming soon…

This all worked great (Win7x64, Guitar Rig 5, Audacity 2.1.0) when I first installed yesterday. But Audacity crashed today when using another VST. Since then it has refused to recognise Guitar Rig again.

I have recopied the Guitar Rig dll into the audacity plugins directory. I have reinstalled Audacity. Rebooted the computer. Got audacity to re read its preferences many times, but no joy.

Checked my Cubase installation - Guitar rig still working fine there.

Installed vst bridge for audacity (didn’t have it before). No benefit.

Any suggestions anyone?



You should remove VST bridge. That was for long obsolete versions of Audacity. Instructions for installing VST effects in the current 2.1.0 version of Audacity are here: Audacity Manual

Thanks for trying to help.

VST Bridge is now removed with no change in the problem. I only installed it after the problem first emerged anyway.

I can’t find anything new in the FAQ pages link you enclosed. The Guitar rig dll is in the correct directory. And it did work. Wonderfully. At first. It is just that it has stopped doing so.


Quit Audacity. Follow the instructions at to open Users<your user name>\AppData\Roaming\Audacity\ then delete pluginregistry.cfg and pluginsettings.cfg as well as audacity.cfg.

If you have not already uninstalled the VST plugin that crashes Audacity, make sure you do not check (do not tick) that plugin in the Register Effects dialogue.

Let us know if that helps. Can you share the name and web address of the VST plugin that crashed Audacity? Does it crash when you enable it in Register Effects, or when you access it from the Effect Menu?


Hi Gale,

Thanks for the help.

Yes, I tried this trick with the cfg files yesterday while I was waiting for my post to be approved on the forum and get a reply. I have just repeated it. Deleted the cfg files and run Audacity to rebuild them with nothing extra in the plugin directory. Then put the Guitar rig dll in the plugin directory as the only addition and restarted. It gets recognised by audacity at start up, but does not appear on the effects menu afterwards. No change.

The vst causing the initial crash was dfx Geometrer. Downloaded so long ago I no longer know where from, but google helped me refind it here: All the other dfx fx work well and still work well with audacity.


Sorry, yes, it caused the crash when opened in Audacity, not on program start up.


Final - I have just tried using Geometer again, and it works just fine in audacity at present. Guitar rig on the other hand, remains absent.


More detailed reading of your FAQ and inspection of my system and its files suggests that my Guitar rig problem is related to me having an 64 bit version on Native Instruments installed, including 64 bit Guitar rig.

However it did work at first! It has just unfortunately stopped doing so.

Will audacity work with some other form of vst bridging software such as j-bridge?


Thanks, yes I find it tends to crash the first time or two in the operating system session, then it’s OK. I filed a bug report here:

That plugin is very old. It crashes the first time or two in an older version of Wavosaur too. In the latest Wavosaur, it does not crash, but the effect sliders have no handles.


If you have the 64-bit versions of Guitar Rig they should never load from the Effect Menu.

I can’t see any evidence online that Audacity definitely accepts jBridge wrapping. Feel free to try it and report back, but I would simply install or reinstall the 32-bit versions of Guitar Rig. And try it with the dfx Geometer.dll moved to your Desktop where Audacity won’t find it.


Tried j-Bridge with audacity - no joy. Bridged files were recognised on startup, but did not appear in the effects menu.

I’m unable to find out whether I can have a dual 32 and 64 bit installation of Guitar rig. I have a full suite of NI products all installed in 64 bit versions, so I am reluctant to mess with that.

Is there a 64 bit version of Audacity on the way? Otherwise I will make do with 32 bit freeware effects. Just adds an extra layer of complexity to using multiple effects for my purpose, which is glitching and reprocessing digital photographs by importing them into audacity, processing them through audio effects, and then taking them back into digital art manipulation software for further work.

I wanted to use Guitar rig because of its comprehensive set of effects and presets, and because there is a clear relationship between what happens to the picture and the audio effect used. For example bass/Treble spread the colour spectrum, delay creates multiple displaced overlaid images. It’s intriguing.

Some of my initial experiments can be found here:

Thanks for your help and advice - I think we have got as far as we can.


I got the TAL Chorus 64-bit and W1 Limiter 64-bit to run in Audacity after bridging them, making sure per jBridge recommendations that the original plugins were not in a path that Audacity scans for plugins.

However the demo version of jBridge is of no value in Audacity because you cannot apply the effect (at least with those two plugins).

That doesn’t really explain why Guitar Rig worked once in Audacity. Are you sure Geometer is outr of the way where Audacity can’t find it?

Not for Windows or Mac. Audacity is 64-bit on Linux if installed on a 64-bit system, but you would need to find 64-bit plugins for Linux that do what you want.