guitar > 6fire > rakarrack > Audacity

greets to all!

…this is run-2, i just crashed 15 minutes worth of composition trying to illustrate my problem :slight_smile:

I would like to go beyond the following tutorial:

and add rakarrack into the chain

{i will call the Terratec usb 6fire as just 6fire for readbility}

i plug the guitar into the usb 6fire because it’s the only way that i can kill the static and such noises

in a terminal i set up alsa mixer to use the 6fire as the (external) sound card

i launch qjackctl because rakarrack requires it

i launch audacity …and this is where i get stuck

in Audacity i can set up

  • Alsa or Jack as system

  • default or 6fire as mic
    …but if i select alsa + 6 fire i lock up (suse tumbleweed in this exercise)

  • default or 6fire or a host of other options as speaker

no matter what i do i cannot record a track and/or hear another

I would prefer to do everything through the 6 fire because that’s where i get really nice sound quality either in or out. But if i cannot make it work i have one of these usb simpletons already ordered. Word on the street is that it’s waste of money and that i should definitely stick with the 6fire though.

I’m also warming up to AvLinux and may try all of this there, once i figure out how to install both 6fire and rackarrack there.

So there, it’s a bit of a thick topic, sorry about that. What should i try next?


If you want / need to use Jack, then use Jack throughout.
Ensure that the sample rate in Audacity (“Edit > Prefereces > Quality”) matches the sample rate in QjackCtl setup. (Keep the sample format in Audacity at the default “32-bit float”).
Leave rakarrack out of the equation initially and ensure that you can record and playback reliably with Audacity, 6fire and Jack.
Does that work?

No. I have to split the topic to Asus-g73-i7-Laptop & Athlon-Desktop because the situation is bad on one and worse on the other :slight_smile:


I think the problem may be related to the fact that this laptop is an asus-g73 with an i7. I Did a complete reinstall. Sometimes just plugging in the usb 6fire caused a crash. Didn’t even get as far as jack. I set 6fire up in alsa mixer, then loaded Audacity. On one occasion as son as I launched Audacity it core-dumped. On the last one as soon as i tried to set 6fire as the mic i got a core-dump, on yet another occasion that came when i tried to set the speaker to 6fire. There’s something weird about the way the driver module behaves. Sometimes it will show up under lsmod but not in use, and then I can’t even set alsa mixer to use it. I tried thrice to upload a picture of the dump and each time I lost everything. This time I’m just going to post this and try the image separately after.


Without JACK:

I can set up Audacity to play an mp3 being monitored while recording. With Audacity set to ALSA, MIC and SPEAKER set to 6fire, I can listen to it all in a headset plugged into the 6fire. This much is covered in the cited tutorial.

With JACK:

When I start JACK a few connections are automatically made. As soon as I set Audacity system from ALSA to JACK the MIC and SPEAKER droplists both lock to ‘system’ and leave nothing to be set. I can play an mp3 and hear it through the computer speaker, which is already strange given that ALSA is set to 6Fire and JACK is set to ALSA. I would think that this would fence out the on board sound card from what’s usable in this scenario. Anyway, while I can monitor on the computer speaker I cannot record anything at all, and I haven’t even touched rakarrack yet.

Bottom line, for now and on this desktop, is to route the 6Fire output through JACK into Audacity. If I subsequently run rakarrack without JACK then that would suit me fine but that does not seem to be an option either.


I can’t help you with this as I don’t know enough about low level audio drivers and I don’t have either a 6fire or an i7. The problem is almost certainly a driver problem, and Audacity requires that fully functional drivers are available, so as far as Audacity is concerned, this is a non-starter until you manage to get the 6fire working properly on the computer.

I think there may be a misunderstanding of how Jack works.
Starting from the sound card hardware level:
The “sound card” is “hardware” that is attached to your computer system. The computer system has no direct knowledge about the hardware device at all.
The computer system only knows about the sound card via the sound card drivers (the ALSA drivers).
Audacity is an “application” (program). Audacity has no direct knowledge of sound card hardware. It connects to the sound card via a “sound system API”.
“Jack” is an intermediate “layer” between the sound card driver and applications.

So the chain of command goes like this:

Sound card ↔ ALSA driver ↔ Jack Audio System ↔ Audacity

When using Jack (Jack Audio System), Jack takes exclusive control of the device. No other application or system can be able to access the device driver, hence the sound card becomes unavailable to all other applications and systems.

On starting Jack, Jack will open connections (“ports”) to the sound card via the sound card drivers. These are called the “system” ports.
Jack can (normally) only connect to one device. Typically Jack creates two input ports and two output ports (stereo) to the device, though if the device has more than two channels available, Jack may create more ports.

When starting Jack with QjackCtl, the device that Jack connects to, the number of ports, the sample rate and other settings should be made in the “Setup” tab before starting Jack.

Jack should be running before you start Audacity.

Many Jack aware applications, when launched, will automatically connect to the “system” ports that Jack has created, thus allowing input and output through the device that Jack is controlling. Some applications require the user to configure which ports to connect to, or to manually make connections via a “patch bay” type application (such as QjackCtl’s “Connect” interface). Each Jack aware application will have its own input/output ports (an “instrument” will usually only have output ports. Effects will usually have both input and output ports). Jack allows connections to be made between input ports and output ports. When using Jack, applications do not connect directly to the sound card drivers, but connect to “ports”, which may be the “system” ports, (hence input / output from/to the sound card), or may be ports of another application.

Jack thereby allows audio connections between one application and another, of between an application and the sound card, via “port connections”. Port connections are always between an output port and an input port. A port may have multiple connections made to it.

On launching Audacity and selecting Jack as the “host” audio system, Audacity will look to see what ports are available. If no other Jack aware applications are running, or if no other application has active ports, then the only ports that Audacity will see are the “system” ports.

Audacity does not make port connections on launch. In fact, Audacity does not have any ports of its own on launch. Audacity currently creates ports “on demand”. That is, when you tell Audacity to “play”, Audacity will create a stereo pair of output ports, and attempt to connect them to the “output device” listed in the device toolbar. When playback stops, Audacity closes and deletes its output ports.

Similarly, when you start recording, or enable the recording meter (start monitoring), the Audacity creates input ports. The number of input ports is determined by the number of channels set in the device toolbar, and Audacity will attempt to connect to the device specified in the device toolbar.

By default, if Audacity is the only Jack aware application running, the Audacity will only see the “system” input and output ports, and will attempt to connect to these when you start a recording or playback stream. As described previously, these “system” ports connect to the sound card device that Jack is configured to use.

In order to use the 6fire with Jack, Jack must be configured to use the 6fire. This should be done in “QjackCtl Setup” before starting Jack.

Thanks a meg for the extensive reply!!!

The g73 laptop has some other issue which seems to be intermittent and which i cannot isolate. Right now it’s working ok.

The mistake I had made was presuming that since I set the alsa mixer up to use the 6Fire device then Jack also using alsa would be constrained to it, WRONG. I did get into settings at last.

Other related hurdles (like the qJackCtl setting dropdown lists opening too narrow to show the full device names and multiples of the same device showing) disposed of, I have managed to monitor in Audacity and record using the 6Fire device and having all audio come out of the headset plugged into it. This, with syst set to Jack, MIC and SPKR set to system.

So, I will drink a beer and ask my bartender to celebrate a mass for your generous soul’s salvation :slight_smile:

Next, on with rakarrack…


All done, updated tutorial:

will shortly replace earlier edition:

Setting up under qJackctl WAS my major stumbling block.

In addition to guidancereceived here, there is a qJackctl tutorial @:–-beginners-guide-getting-started-jack