GUI lagging when selecting audio waves

When I click to make a selection on audio material, I notice a lag between the moment I press the button moving the cursor and the moment the graphic interface let me see I actually made the selection (coloring the selected range). It’s very annoying and it wasn’t happening before I started to use macos 10.15.1 + audacity 2.3.3.

Thanks for the feedback. This is the second report of this issue that I’ve seen. Unfortunately we have not been able to reproduce the issue, and don’t know why it occurs for a few users.

it could be useful to know that I am using a 16 inches macbook pro… maybe this is not happening for other macbooks.

Thanks. The other case is on Windows 10.
Were you previously using an earlier version of Audacity?

yes, I was using audacity 2.3.2 and I was not on Catalina.

Try setting “Snap-To” to “Off”

Snap-To is already on OFF.
I tried to install audacity on a Windows 10 virtual machine and it does not have this problem… it is so weird :slight_smile:
It has to be bound to Catalina.

How are you launching Audacity?

Have you given permission for Audacity to run? The way to do that is to launch Audacity from the Dock with “Right click” and select “Open”. By default, Gatekeeper will complain that the developer cannot be verified, so you need to confirm that you wish to run it. Let Audacity launch, then Quit Audacity. After doing this once, you would then use the “Terminal” trick to launch Audacity.

I tried to launch Audacity from the Terminal, but it is the same thing than launching it from Launcher or Dock.

I actually face exactly the same problem. GUI keeps lagging. Whenever I resize window or select part of the recorded wave. It is so annoying!

Anyone found solution for that?

Yep. I am using Mac OS Catalina and I use “Terminal trick”. Otherwise I won’t be able to record anything :neutral_face:

I just upgraded to macOS Catalina 10.15.5 and installed Audacity 2.4.1

I’m having the same problem. Very high latency in the GUI. Making it really hard to be precise about making selections in the tracks.
I read some other threads about mic problems with Catalina and the “terminal trick.” I don’t usually record anything with Audacity on this machine, just import audio files for editing/mixing. Is the “terminal trick” anything that might help with this? It would be awkward to have to launch Audacity through the terminal every time, however.

I was previously running Audacity 2.1.2 before the OS upgrade and didn’t have any problems.

This is my Mac configuration:

iMac (Retina 5K, 27-inch, 2019)
Processor - 3.6GHz 8-Core Intel Core i9
Memory - 32 GB 2667 MHz DDR4
Startup Disk - Macintosh HD
Graphics - Radeon Pro Vega 48 8 GB

The “terminal trick” is only needed to get permission for Audacity to use the microphone. It will not be needed in version 2.4.2.

The issue is with retina displays. I have version 2.4.1 running on my retina iMac (Mohave) and non-retina Macbook (Catalina). The UI is laggy on the iMac and not on the Macbook. It is not Catalina, since my (laggy) iMac is running Mohave.

We are aware of the problem but it has been devilishly tricky to track down.

In the meantime, I never use click-drag to make long selections particularly if it causes scrolling. I click at one end of the selection then shift-click near the end and trim it. The shortcuts detailed here may help you as they will play short portions at the beginning and end of the selection. If you use them a lot you can set custom keyboard shortcuts in the Keyboard Preferences.

– Bill

Yeah, it’s more than just clicking and dragging in a track to make a selection; even trimming is very jerky. If the number of tracks exceeds the window size, scrolling through the tracks is painful. Same with just resizing the Audacity window on screen. Hopefully it will get resolved.

Thanks anyway!

I agree. I’ve raised the issue with the developers.
– Bill

To everyone who has reported “GUI lagging” problems on this thread …

Please go to Apple menu > About this Mac then click “System Report”. In the system report, under Hardware, click on “Graphics/Displays”.

What do you see for “Framebuffer Depth”?

– Bill

There is a workaround that will make Audacity snappy again on 30-bit displays.

Right-click on the icon and choose “Get Info”. In the Get Info window, check “Open in low resolution”.

The GUI might look a bit fuzzy in places but Audacity will be “snappy” again.

– Bill

“Low resolution” mode fixed it for me.

The GUI is a little soft, but I’ll take that vs the herky-jerky.