GUI lag/slow performance on 4k monitor

Hi! I’m seeing a lot of GUI lag while doing basic operations like selecting or using the envelope tool. I saw similar threads being reported for MacOS but not for windows. Like majority of the users facing the problem in MacOS, I’m using a high res monitor (3840x2160).

Audacity version 2.4.2 running on Windows 10
System details: Core i7 8700k, 32 GB of RAM, Nvidia GTX 1070ti

Saw in the macOS thread that version 2.3.0 worked much better, so I tried that version - and it does indeed lag much less, especially while using envelope tool. Resizing the window to a tiny one also reduces the lag.

I think it’s still true that no matter how powerful your machine is, Audacity is only going to use one core. It’s also going to fall to the bottom of the priority stack. How many other things do you have running, and do you have a cloud connection mounted along with local storage?

Disconnect the network. Kill the WiFi and/or pull the network plug from the machine. Then clean-shutdown Windows. Shift+Shutdown > Wait > Start. Did the problem change either way?

It’s also possible that Audacity doesn’t know anything about special display drivers. I assume you can watch a full-screen movie or video without stuttering or bad sound sync.

I discovered a sync error in my office machine. I always thought dance/music videos were sloppy and that was that. No. The first time I saw the same video on my laptop, the picture/sound sync was perfect.

Now that I know it’s there, I can just build it into production. Or don’t produce anything with techno and dance in the same scene.

Screen Shot 2020-06-28 at 20.09.25.png

I’ve tried with just a few chrome tabs are open - lag is still present. No network storage, project is stored in a local sata ssd. I’ll try disconnecting from the network and clean-shutdown.

No other performance problems, playing full screen videos and games work great. Even in Audacity, I experience no issues with recording, exporting, adding effects etc. Just the UI is extremely laggy.

Just as an illustration, I captured working on the same project in both v2.4.2 (installed the usual way) and v2.3.0 (portable download) back to back.
v2.4.2 (lots of lag, UI responds to mouse after almost 0.5s):
v2.3.0 (UI responds way faster):

This also occurs on Mac, and we think we’ve tracked down the source. The GUI lag happens on monitors that are 30-bit. That is, the “Framebuffer Depth” is “30-Bit Color (ARGB2101010)” (as reported by the Mac System Information utility). One workaround on Mac is to set Audacity to “Open in Low Resolution” mode.

Is there a similar option on Windows?

– Bill

So I tried this out on my 6-core iMac 27". I opened a large project, opened Activity Monitor below it, and opened the CPU Usage window (which shows a graphic of the activities in the 6 cores). Drag-selecting in the project (which exposes the GUI lag), Activity Monitor showed Audacity using about 112% CPU (implies more than “one-core’s-worth” of CPU time), and the CPU usage window showed activity across all 6 cores. The next-highest CPU % was Window Server at about 3%. This was all with Audacity NOT in low-resolution mode. I quit Audacity, set it to open in low-resolution, and tried the same thing, with the same results for CPU usage. So it seems we can rule out CPU usage limitations - in both instances CPU % was about the same, but the low-resolution mode speeded things up. The bottleneck seems to be re-painting on 30-bit displays and the lag does not seem to correspond to increased CPU usage.

If you are having issues other than GUI lag (such as dropouts when recording), then it is certainly possible that other processes are competing for CPU time. But I think we are confident that the GUI lag is tied to two things: 30-bit displays, and a change made in version 2.3.1.

Until now I had only been aware of problems on Macs with 30-bit displays. That this problem also occurs on Windows machines running 30-bit displays may help the developers track this down.

– Bill

According to a Windows user on our QA list:
In the properties dialog of an application (or a shortcut to it), on the Compatibility page, there’s an option for a reduced colour mode, which has a choice of the number of bits.

– Bill

Thanks for the suggestions! I tried out working completely offline, fresh shutdown and start up, enabling 16-bit color mode in compatibility settings, but nothing has helped so far.

I’ll keep using v2.3.0 and try out newer versions when available.