GSNAP malfunction

I have downloaded the 32bit version of Gsnap, copied and pasted the .dll file into the plugins folder. I have the latest version of Audacity and when I click “Add effects” Gsnap doesn’t show up in the “New” section, only shows up in “All” section. It is disabled by default so I click “enable” and then “ok”. Still though after the tab is closed, Gsnap doesn’t show ANYWHERE. I followed every step correctly, watched EVERY youtube tutorial there is, tried EVERY POSSIBLE way but still NOTHING happened. I am very frustrated please someone help me solve it.

Does it now say that it’s enabled?

No it goes back to disabled once I click ok and the tab closes

I would double-check that it is the 32-bit version
(behaviour described is what happens with 64-bit versions)

A free alternative to GSnap is Grallion2

No man it’s for sure the 32 bit version I’ve redownloaded it a million times now. Thanks though I’ll check Graillon out!

So I have just tried this now on audacity 2.4.2 on Windows 10. I downloaded to my Downloads folder. Double-clicked on to open up the contents, then dragged GSnap.dll over to C:\Users\xyz\AppData\Roaming\audacity\Plug-Ins, where xyz is MY name (NOT Default and NOT public). Before I did this, I opened up the Plug-ins folder (I actually could have done this on any folder), clicked on the View tab at the top of the screen, then in that top panel, made sure that “File Name Extensions” and “Hidden items” were both checked. When I did this, Gsnap appeared in the Audacity “New” Plug-ins list, so I clicked on it and enabled it. So this worked fine for me.

Now, to stress the situation and give you some ideas, I returned to the C:\Users\xyz\AppData\Roaming\audacity\Plug-Ins folder and renamed GSnap.dll to GSnapx.dll. Audacity didn’t like this. When I restarted audacity, GSnap was no longer in my effects menu. However, GSnap and GSnapx were BOTH in my Manage Plug-ins Folder. GSnap marked disabled and GSnapx marked new. Trying to Enable GSnap gave me the same results you are experiencing. Enabling GSnapx, installed GSnap just fine!

So I am thinking if you copy GSnap.dll to C:\Users\xyz\AppData\Roaming\audacity\Plug-Ins, but then rename it to GSnapx.dll, you might get that to work. Good Luck!