Gsnap/GVST Not Enabling or Showing Up

Hello, I have been searching through the forum and online for a while now and have yet to find a solution for Gsnap not appearing.

I have Audacity 2.1.2 zip and am using a 34 bit Gsnap. When I try to enable the VST plug by Adding it, it won’t show up in the Effects list even if I restart the program. Following the pathway for Managing (Edit > Preferences > Effects) also doesn’t work as it doesn’t have a ‘Re-scan for VST’ option and VST is already checked. A prompt does not appear for me to re-scan when I start up Audacity again either.

I’m at a bit of a loss of what to do.

Thank you for taking the time to look over this in advance.

I assume you meant you got the 64-bit GSnap when you say “34 bit”. Audacity requires 32-bit plugins on Windows.

Audacity 2.1.2 no longer has a Preference for rescan - a rescan happens when you open Effect > Add / Remove Plug-ins… . You don’t need to restart Audacity after enabling a plugin there.

After enabling a plugin at Add / Remove Plug-ins…, click OK, not Cancel or red Close button, and don’t escape the dialogue.


Sorry I didn’t reply until now, my email didn’t alert me that this was updated.

Yes, sorry I meant 32 bit not 34. As I mentioned before, I’ve looked over many threads on this topic in search of an answer so luckily I already know not to download the 64 bit!

I’ve followed that path quite a few times and I always press ‘OK’, not cancel. Whether I restart the program or not, the extension isn’t listed.


Make sure you are subscribed bottom left of the topic, and check your trash or spam folders in the e-mail application.

There is no need to restart Audacity after OK in the Plug-in Manager.

Make sure at Edit > Preferences…, Effects section that “VST” is checked (ticked).

Also you could try opening File Explorer, type


into the Explorer address bar, hit ENTER on your keyboard, then delete the file “pluginregistry.cfg”. This is in case any corrupt registration entries are preventing you enabling GSnap.

Must you use GSnap? Audacity doesn’t support GSnap fully because it doesn’t support GSnap’s MIDI tuning. You can try Autotalent for Windows (VST):


The VST was already checked, but it seems like deleting the cfg file did the trick! I’ve downloaded Autotalent as well, but there aren’t any tutorials out for it yet so I’ll stick with GSnap for now!

Thank you,


here’s what i’m trying to load into audacity. i don’t need a tutiural for this:

CCSequencer has nothing to do with GSnap.

Audacity does not support VST synths (VST instruments) or MIDI input/output, so there you have two good reasons why that plugin doesn’t work in Audacity.


it did work at one point and i’m talking about it not showing up.

It appears in Audacity latest build and does nothing useful as far as I can tell, and as expected.


Please help me. Gsnap is just not appearing no matter what I do. I have enabled, I have ticked VST and I have deleted pluginregistry.cfg but to no use. Can anyone tell me what the problem is?

this is quite late but i hope you see it
i had the same problem as you but its actually reallys simple to solve.Once youve deleted the pluginregistry.cfg and ticked VST: GSNAP wouldve been installed and i guess just like me you couldnt see it. All you have to do is scroll down in the effects section and below wahwah you will see a line and then more effects click the arrow at the bottom and you should see GSNAP

Hi, this solution is for Windows, Just remove the audacity version you have, download Audacity 3.0.2, and check on “reset preferences” box, after installing,download Gsnap plugin 32bit for windows,copy the Gsnap.dll file in audacity plugin folder, then start audacity and enable gsnap from 'Effect->Add/Remove plugins, you’ll be good to go.