GSM 6.10 raw binary file not showing any output

I am collecting raw binary data of 260 bits (decoded bits) of GSM full rate speech codec for every 20ms from the Base station simulator. configuring the GSM simulator for 300Hz sine wave as input.
I have binary file with 260 bits appended for every 20ms for 1minute (file_name.bin).

When I tried importing the binary file, I am not getting the sinewave in the audacity window. only single line with dots are visible when I load the binary file.
Find the screen shot below for the configuration and output window after loading.


  1. Should I add any header data along with the decoded bits (260 bits) before importing?
  2. Is there any specific configuration while importing raw data?

Any help is appreciated.

I don’t know anything about GSM, but it’s not “raw” uncompressed PCM so I’m confused by the GSM option under “raw” import.

Besides the fact that it’s silent (or nearly silent) I assume the playing-time is also too short? …For two reasons - You’re probably looking at the compressed data, and it’s probably supposed to have a sample rate of 8kHz.

I don’t know if there’s supposed to be a header… Probably not with a .bin file. And, it’s usually a stream rather than a file…

If you open a WAV file as raw, the header simply gets converted to audio (a short noise glitch). And, it can throw-off your byte sequence so you might need an offset. (Or you can enter an offset that’s large-enough to skip-over the header.) That’s an “easy case”, because a WAV file is essentially an uncompressed raw PCM file with a header tacked-onto the front telling the software the bit-depth, sample rate, and number of channels, etc.)

And if you do have a header (and the correct CODEC) you don’t open as raw… The header tells the software what CODEC to use and how to decode/decompress the file so the file opens/plays correctly.


Thanks for the Quick response :slight_smile:

Firstly, As you said we are having binary file (stream of data’s). Not with the header.
Secondly, The binary file is of more than 30 seconds.

We are importing with “raw data” as option even though it is Binary file.
I tried with different PCM options for encoding while importing raw data, We are getting sound and discrete points in the window.
I tried with GSM 6.10 encoding options, we are getting silent noise with plain line in the window.

While importing Raw binary, should header be patched with the pay load data?
Header means (vocoder type, SID valid bit, BFI frame …)

To add on…
The binary file is for the call more than 30 seconds.

Try looking at the file in a hex editor. Does it contain reasonable data?


Yes. Since it is sine wave input with defined frequency, It is represented with the repeated data when we looked in to hex editor.
But again this is only payload since it is raw file.

Does the track length in Audacity match the expected length calculated from the file size?
Have you tried amplifying the track to see if it is really totally silent (The Amplify effect will show the amplitude of total silence as “-infinity”).