Going crazy, usb input recording on mac

I’ve read as much as I could, googled high and low and can’t find a solution to this. I’m using a Xone 96 mixer with soundcard, outputting to my macbook (tried 2 different macs). In my macs sound settings I see Xone 96 as an INPUT, i select it, the mac is getting an input, the bars move at the same time as the bars on my mixer and stop when I pause my decks.

On audacity I select Xone 96 as an input, stereo recording, built in output. But I get no input on audacity. I tried restarting it multiple times including restarting the mac. I click start monitoring to see input, but it stays at 0.
When i use built in mic I see the gain right away.

In audacity preferences (Devices) I’m on core audio for host, xone 96 for input, built in output, 2 channel stereo.
I feel like I must be missing something and 4 sleepless nights with a newborn can do that to a man.

Any help ?

It could be this problem: https://forum.audacityteam.org/t/no-recording-level/51788/1

I was having the same issue with Scarlett 2i2 4th gen using Sennheiser MD 46 microphone. Audacity won’t recognize inputs on mono track recording, but it records fine on Stereo tracks. Sadly, it also plays back at the same time so there is latency in your headphones but it doesn’t impact the recording. If I figure out the playback problem I’ll post that solution.

Transport (menu) > Transport Options > Enable audible input monitoring (uncheck).

Thank you. That was it!