Getting an echo on record

Getting an echo on record. Any ideas ?
OS 10.12.6

What version of Audacity? What Mac? What is your recording device? What is your playback device? Is Software Playthrough turned on?
– Bill

“What version of Audacity? What Mac? What is your recording device? What is your playback device? Is Software Playthrough turned on?
– Bill”

2.2.2, see jpg, Saphire pro 14 soundcard for rec & play, Don’t know if Software Playthrough is turned on. Can’t see which drop down menu that’s in ?
Screen Shot 2018-10-11 at 22.55.42.png

So that would be a Focusrite Saphire pro 14.

Are you overdubbing?

We can’t see what you’re doing, so all we know is what you tell us.

If you are overdubbing, plug your headphones into the Saphire, not the computer. Set the Saphire up as both recording and playback devices and then go into Audacity > Preferences > Recording. Select [X] Overdub and not [_]Playthrough.

That any better?

There’s a whole thing about overdubbing setup.


Hi Pobinr, Billw58 and Kozikowski

Thanks for your query.

It sounds like you may be listening back to the input source while recording both through Audacity and the Saffire - if you’ve got your speakers/headphones connected to the Saffire directly.

If so, I would recommend having only one of the two listening back options turned on.

I believe you are familiar with Saffire MixControl, which is the routing software that the Saffires use.

As shown in the screenshot

there are channel strips which can be assigned to the hardware inputs on the Saffire - ‘Anlg In 1’, ‘Anlg In 2’ etc.

It looks like you may have got a channel strip assigned to the input on the Saffire to the Mix in Saffire MixControl > your speakers/headphones, which you’re also hearing from Audacity.

I would recommend muting that particular ‘Analog In…’ channel in MixControl by hitting the corresponding ‘M’ button.

Hope that fixes it.

Keep us posted on how you get on.


Hi Anantha & Koz

Ref… Are you overdubbing?
It does it when recording 1st track.
I’ll check out your comprehensive advice & let u know how I get on. Many thanks

Yes my speakers run off the Saphire output jacks
If I turn down slider for DAW1/DAW2 then no echo when recording. But no sound on play back of what I record.
Don’t know what changing analogue 1 or 2 would do. They can only be turned on or off, not reassigned as far as I can see
Screen Shot 2018-10-12 at 22.04.50.png

I’m getting either instant programme shut down or it hangs as soon as I try to play what I’ve recorded !
Downloaded latest version too !
Also echo stops if I turn down audacity playback vol. Though that’s a minor nuisance as I keep having to turn that back up to listen on replay.
Never had an echo problem in years gone by with audacity, so never had to turn down playback on record then turn it back up to listen.
I’m baffled. I haven’t changed my set up !
Dismayed as otherwise I think Audacity is a great audio recording DAW & editor
Screen Shot 2018-10-13 at 20.56.06.png