Getting a flat line while recording guitar - have tried everything


I’m using Windows 10 and the latest version of Audacity. I have connected a Behringer U-Phoria UM2 audio interface to my laptop and am trying to record guitars through Audacity. Every time I try, I get a flatline. The interface is getting a signal from the guitar, and I can hear the guitar playing as well. But every time I try to record, I don’t get any sound.

I have changed the microphone to USB Audio, tried mono and stereo channels, tried the USB speaker output as well as the laptop speaker output. Tried the MME, WASAPI, and Windows Direct host options. Connected the interface to the laptop first, checked to see if it’s working, and then opened Audacity after that. Have ticked on the Overdubs, Software playthrough of input, Record on a new track, and Detect dropouts options in Recording Preferences.

I’ve gone through many similar entries on these forums but none that worked. Any help would be much appreciated!

Dunno if this helps or not. I had the same flat line issue, albeit using a mixing desk rather than a Behringer interface thing (I did try one of those, but it just didn’t work despite everything suggesting that it should do…I think it was something to do with the drivers, but that’s another story.)

Anyway, the flat line thing…mine eventually just sorted itself out. All I did was to uninstall the Microsoft HIgh Definition Audio device in Device Manager then scanned for new devices at which point it re-installed the driver. Despite the fact that I think it was the same driver as previous, it worked after re-installation.

Hope you get it going. Good luck.

I run Windows 10 1909. I have also had this problem, probably after a Windows 10 update. After reinstalling the audio driver software (Realtek Audio) on my pc (Dell laptop) the problem was solved.

Thanks everyone, it’s solved now - had to go into the sound settings of the interface and change the recording setting from 1 channel to 2 channels.