Generating silence produces noise in the high frequencies

The option “Generating …” “Silence” produces noise in the high frequencies (Win7 Professional, Audacity 2.2.2).

Noise is observable after doing the following steps:
0) Import some wav-file.

  1. Induce silence with an arbitrary duration (German: Erzeugen … Stille). Now, you do not see any noise (first row in the pic).
  2. Export your file in the same format as the original.
  3. Import your new file.
  4. Look at the spectrogram, especially in the high frequencies. Noise is visible in the silence part (second row in the pic).

Has anybody observed this, too?

Best regards,

It is normal for exporting to create a tiny bit of noise due to downsampling from 32-bit float to 16-bit.
The amount of noise in your image appears to be much greater than the expected noise, but could be due to your spectrogram settings.

If this is low-level noise that you can’t hear and you can’t see in the normal waveform view it’s probably [u]dither[/u]. If you want digital dead-silence, turn-off dither.

If you want digital dead-silence, turn-off dither.

But that can be dangerous. Dither is there to avoid distortion caused by conversion of Audacity’s super high quality internal format down to 16-bit for export. You might be trading an inaudible, very low volume dither signal for very audible conversion artifacts and distortion.


But that can be dangerous.

I wouldn’t say “dangerous”. At 16 bits or better you normally you can’t hear dither or the effects of dither. And dither is (very low-level) noise so if you want true-silence you can’t have dither. (Of course, there will always be some analog noise after digital-to-analog conversion which you may, or may not, hear.)