Garbled recordings on new Mac

By the time I get my “new” Mac set up it will no longer be new?!

Here is my environment…

  • Retina MBP, macOS Sierra, 10.12.6
  • Audacity 2.2.2

(This is a late 2015 MacBook Pro that I have never had the time to get completely set up, and so like a fool I am still relying on my ancient MacBook running Mountain Lion 10.8.5 and Audacity 2.0.3. However lately my old Mac keeps dropping iInternet connections, so I think it’s time to get my not so new Retina working finally!)

I had posted in the forums last Fall 2018 complaining that when I record the graph (?) output is jerky.

When, over time I have also noticed that as I record radio shows that not only is the <I don’t know what to call the graph Audacity displays showing your recording> still “jerky”, but that over a period of time it doesn’t match up recording time.

For instance, the graph might show I have been recording for 1 hour and 10 minutes when the counter in the bottom bar shows 1 hour and 25 minutes.

I found out at the end of last year that when I would record a radio show before bed time that in the beginning the recordingw as doing okay, but after maybe 2 hours, the recording would go to hell and almost sound like you were recording two different radio shows at once - out of synch of course!

It almost sounded like Audacity was getting to the end of the proverbial tape and then going back and continuing to record over the first pass so the end result was a double recroding.

Seemed like some kind of caching/buffer overflow issue.

Today I was recording Casey Kasem’s AT40 countdown on my Retina because I was simultaneously rceording anothers how on my working old MacBook.

Because of the above issues, I broke up the show into 4 recordings, hoping each was small enough to prevent the issues I mention above.

After the show was done, I went back to make sure I had got all 40 songs, and on the last recording, a few minutes in, it went from a clear recording to all garbled up - meaning the whole radio show was crap!! :imp:

WTF is wrong with Audacity on this newer MacBook Pro?!

Between this issue, and struggling to get Zoiper and Lookback and Audacity to work on this new Mac, I have barely sued it after owning it for a couple of years?! (I have so much else on my plate, and just don’t have the time to spend week after week trouble-shooting on a new computer that should just work out of the box?!)

I would really appreciate some help figuring out what is going on, and finally trying to get completely migrated over to my Retina before my 2012 MBP ends up dying on me - which I am sure it soon will!


P.S. I can post an audio sample online if need be…

<I don’t know what to call the graph Audacity displays showing your recording>

That’s the audio waveform or “blue waves.” Thicker is louder up to when the waves touch 100% either up or down. That’s where distortion sets in, so don’t do that.

when I record the graph (?) output is jerky.

The legacy version of this is record one screen worth of waves and then switch rapidly to the next empty screen and fill that one up. There’s a second way to view the waves where they only move when you tell them to no matter what you’re doing. That’s the one you want when you’re editing and don’t want your edit point and critical adjustments to move or slide out from under you.

a late 2015 MacBook Pro

So it’s close to going out of extended warranty if it’s not already there. And that’s your new machine.

struggling to get Zoiper and Lookback and Audacity to work on this new Mac

I considered your symptoms seriously abnormal and complete chaos until right about there. By my count you have between five and six different sound apps on your machine. Are you sure you don’t have Skype on there? That would be seven. Zoiper, in particular, I would expect to be at the top of the food chain and everybody else gets the audio table scraps.

Macs have no natural way to record their own playback or internet shows or music. So one of those apps is supposed to handle that, too. Again by my count, that would conflict with Zoiper. The Mac has only one record and one playback pathway unless you make new ones, and that sharing can be a bloody battle.

You no longer have a casual “Everything Just Works” Mac.

I suspect everything would work a lot better if you closed everything, restarted the Mac and only used one thing at a time. You might find that some of the install and configuration processes would work a lot better if you did that.

Do you have it set so you get little markers or lights under each active application in the Dock? How many lights do you have on?

Screen Shot 2019-04-14 at 20.22.36.png


So let’s get the easy stuff out of the way in this thread…

When I am recording an Internet radio show, I want the audio waveform to move along smoothly in perfect timing with the music.

As long as I have used Audacity (i.e. maybe 10 years) that is how it has worked.

Now when I record on my Retina, there is a red vertical line to the far right that moves along, and then behind it is the audio waveform. The problem is that the audio waveform doesn’t move, and then like a half-a-second later it “snaps” to try and catch up with the redline.

And the longer I record, the more noticeable this latency becomes.

In addition, the audio position counter is also “jerky”. The number increases, and then it will pause for a moment, and then increment very quickly. It looks like it can’t keep up with the music. (On all prior version of Audacity, the counter increases as a steady rate as you would expect.)

Is there a preference I can change to address these issues??

Yeah, but that is misleading…

My Retina is the last real laptop Apple will likely ever make. It has a removeable battery and hard-drive. The keyboard actually works. It isn’t a solid-state appliance like all new Apple laptops. And I think is of traditional good quality that new Apple products seem to lack…

Yes, audio is a major PITA on Macs, no doubt!

Funny comment about Zoiper, because I do not own a phone, so yeah you would think that working VoIP would be my lifeline. But then as someone who created (?) Audacity, you can appreciate that music and recording is a large part of my life! (If Zoiper doesn’t work, I can still write letters. But if I miss my favorite radio shows each weekend, then that is true chaos!!) :laughing:

I pissed around for a couple of months last Fall 2018 trying to get all of this set up, and it was confusing as hell, because I have things working on my old MacBook, but I don’t know how things work - I have a working bird’s nest/fubar on my old Mac that doesn’t translate to my Retina.

So I thought I had things mostly working, e.g. make Zoiper calls, record Zoiper calls, record from browsers (i.e. radio shows), record from VLC/iTunes (i.e. radio shows), proper playback, and so on. Then I ran out of time, and decided to get back the a business I am trying to start - which relies heavily on all of this audio stuff. And for the last 6 months I have been focusing on that.

But now my old Mac is so old and starting to become incompatible with websites and Wi-Fi (?) this weekend, I was like, “I better get my sh*t together and get everything migrated over to my damn Retina and get on with my life?!”

And so here I am…

FWIW, all I was doing yesterday afternoon was recording a radio show off of FireFox and some casual browsing, although I was mostly working on my old Mac.

So unless I have something screwed up in Loopback, all of these other apps that I have are immaterial as they were OFF.

Furthermore, if I had some initial setting wrong in Loopback or whatever, why would the recording be fine for the first 30-40 minutes and then start to degrade? I think this is totally an Audacity issue…

As mentioned, for maybe the first 30-40 minutes, recrodings are fine, and then (while listening to the playback) I start to hear all of these background sounds - like someone is talking in the background or in the old days on analog radio where another radio station’s signal would creap into a broadcast with a week signal.

When I first discovered this, I thought it might be related to the jerk audio waveform and I hypothesized that this was a buffer issue or something where Audacity was re-recording over itself.

I dunno… Have been using Audacity for like 10 years on Macs (and Windows) with good results until now.

Trying to get my website and business up, but looks like I need to revisit all of this audio stuff and get it mastered so that I don’t have any more issues, and when my old Mac finally dies, I have a reliable way to record radio shows (and make VoIP calls and all of that other stuff I need/want)!

Hope that description helps somewhat?!

I don’t disagree, and Loopback is supposed to be the “silver-bullet” that fixes all of that.

Nothing on my life is “Everything Just Works”?! sigh

As mentioned, all I had open yesterday was Audacity, Firefox, Finder, and OpenOffice.

It’s not that Auadacity won’t record decent recordings, it that after 30-40 minutes it is recording over itself. (In the past, I would wake up in the morning, only to find out that “Internet Show A” had faint voices from “Internet Show B” in the background, where Show-A played maybe from 9pm-1am and then Show-B played from 1am-2am.)

See above. Nothing else is/was on.



Would it help if I posted my Audacity project and an MP3 of the problematic recording?

Hearing is believing…

Hearing is believing…

Oh, I do believe you. I had a Mac do something like that on a simple recording several years ago. It split up the sound and recorded some here, some there, mostly overlapped. Only did it once.

Besides you wouldn’t get very far. The data limit on postings is 2MB. That works out to 10 seconds of stereo WAV. A bit more in MP3. Not even that much on a Project.

Desktop > Go > Utilities > Activity Monitor. I think it will be an eye-opener seeing who is taking the machine resources—and I do think you are running out of resources. Audacity will prioritize recording the actual show over updating the screen.

Screen Shot 2019-04-15 at 12.13.06.png
A couple of months ago, my machine went into fan cooling and performance just started grinding. One of the FireFox Web Content processes was helping itself to 99% of my processor. I keep Activity Monitor closed, but on the pop-up Doc now.

You may be in the Twilight-Zone condition that what you had before was broken. What you have now sounds perfectly normal to me.


Do you have a Solid State Drive? I have for several years and machines. One of the Systems Operators at work and I had very similar Mackbook Pro machines except he had spinning metal and I had an SSD. I had to do a quick process on his machine (with his permission) and I thought it was broken. I could have gone for a Starbux Latte waiting for the responses to my commands [sound of a record running at half speed].

No, he said. That’s normal.


I wouldn’t think that would be a good machine to do production, much less multiple productions. Too much production depends on real-time data management.


But I have a website on which I could post things…

I’m doing a test now, and I see…

System: 5%
User: 19%
Idle: 74%

Of course the issue seems to usually happen after an hour into my recordings…

You lost me on that comment…

I have a 16GB of RAM, a 1 TB HDD, and a SSD.

Plenty of horsepower for what I am doing with Audacity, and much faster than my 2012 MacBook which works perfectly recording with Audacity…

Why no replies, @kozikowski?

You may have an extreme version of this “clicky recording” problem:

@Steve, I just sent you a PM…

I tried the advice in that link and it didn’t do anything to help.

Starting to think I’m really f***ed on this…

Truth be told, I haven’t ever used or relied on recording radio shows with Audacity on my “new” Retina because the migration process from my old laptop has been such a PITA.

I think I have a couple of serious issues that I never noticed until now… (Because I never listened to what I recorded on my Retina.)

Issue #1:
The audio waveform and track “counter” seemed “jerky”…

Issue #2:
When recroding long Internet radio shows (i.e. 2-4 hours), things start out okay, but after maybe 40 minutes, when I go back and listen to the recording it shoulds like there are two radio shows recroded over each other. Almost like Audacity gets to the end of it’s 1-hour tape and then keeps recording over the first part of the show. It is subtle, as the main show is usually dominant, but it trashes the recording.

(On my 2012 MacBook Pro, I can turn on Audacity 2.0.3 on Mountain Lion and let it run for 12-15 hours with no problems, which is awesome, when I want to record a day of radio shows but can’t be at home!!)

Issue #3:
Not sure if they were there before in Issue #2, but now I notice clicking when I did a short 30 secord test recording on a smooth jazz radio station on VLC.

I made the changes you recommended above, but no luck.

Recording my favorite radio shows is a BIG part of my free time, and it is very depressing that I cannot get Audacity working my my Retina MBP with Sierra. :cry: :cry:

I sorta put the whole audio thing on hold last Fall because I have been so busy trying to get my business up and running, and like I said, migrating my life from my old Mac is just too time consuming, so I find I still use my old Mac more than my new Mac - ironic!!

I sent a PM to you, Steve, and Kozikowski, hoping to give you alink to a test website where I posted some samples of this craziness that I am experiencing. (Nothing personal, but I don’t want to just post the URL here because I don’t want the whole Internet hammering my web server, but I don’t mind sharing it with a handful of people here that want to try and help out.)

I owe a big THANK YOU to the creators of Audacity, as you have brought me over a decade of happiness being able to record radio shows and capture them for later listening in the future. Audacity has been a fabulous tool for me, and it has almost always worked. But as I have been busy trying to migrate my life off my old Mac and get my business going, I have come to realize something is really F***ed up with Audacity on my Retina… :frowning:

Here is hoping I can get it fixed and start using my new Retina before it rusts!!


Why no replies, @kozikowski?

I have no idea how to solve this. The forum doesn’t win everything.

Post back if you find out what the problem was.


I’m surprised you’re giving up so easily, Koz. In the past you had an answer for everything!

Wouldn’t it help if you could hear and see what I am experiencing? (I posted some samples on my test website.)

Have there been reports of anything similar to what I describe with Audacity 2.2.2 on macOS Sierra?

Would I be better off upgrading to a newer version of Audacity? (Or possibly “downgrading”?)

I am willing to troubleshoot, but you guys are the experts on your software, not me…

I got lost in your descriptions. You speak of two different machines: do all of these problems occur on both machines?

I have a MacBook Pro, 2012, with Mountain Lion on it and Audacity 2.0.2. And I use this laptop 90% of my day/week. It works great, but the keyboard is failing, I have had to replace the guts, and it’s a matetr of time before it croaks! The bigger issue is that I cannot upgrade to the latest versions of Firefox and Chrome because my OS is so old. And I don’t want to upgrade the OS, because this laptop actually WORKS!!! (Audacity works flawlessly on this old MacBook Pro.)

In addition…

I have a nearly unused, “cherry”, 2015 Retina MacBook Pro with macOS Sierra on it and Audacity 2.2.2. THIS new(er) laptop is the one that is causing me grief and is what this thread is about.

Make sense?

What is the “Loopback” that you spoke of?

Does your Mac have a microphone? If so, does Audacity work correctly if you record with the microphone?

Loopback is software from Rogue Amoeba that allows you to address Macintosh coputers horrible handling of audio.

It is basically like a mixer where you can do from very basic to very sophisticated things with audio on your Macintosh.

In order to be able to record an Internet radio show being played in VLC/iTunes/web-browser in Audacity, you would either need a tool like Loopback, or the software that it replaced which you may have heard of called “SoundFlower”.

In fact, on my 2012 MBP, I am using SoundFlower so I can record radio shows in Audacity.

My Retina has an internal microphone. And it captures sound, but as you’d expect on a laptop the quality is horrible.

I’m not surprised that the quality is horrible, but my question is, do you get the same weird problems that you get when using Loopback?

I just did a 30 second test run uisng my internal mic.

The recording sounded okay exceot toawrds the end it sounded staticee for just a second.

Sorta hard to tell because the mic’s quality isn’t good, and of course, my stupid refrigerator came on during the test!

When I record off of VLC or Firefox, the noise is much more pronounced and sounds like scratching a record or when you rub the antenna of a transistor radio against somethng.

Just sent you a PM with a link…