Freezes when keying in Japanese

When the language is set to “Japanese” and keystrokes are made, Audacity freezes and does not accept any input.

Confirmed in Audacity 3.0.4, did not occur in Audacity 2.4.2.
It probably happens with Audacity 3.x.

It seems to happen when using Microsoft IME from Windows 10 version 2004 or later, so if I turn on the “Use previous versions of Microsoft IME” option in Windows, it will not freeze.

The OS is Windows 10 version 20H2 (build 19042.1165).

It’s a bug in Windows 20H2 (and 2004).
Microsoft claim to have fixes available:

I updated windows to 21H1 and it didn’t freeze anymore!
Thank you so much!

Thanks for the update.
I’ll close this topic as solved.

I’m really sorry. I’m sure it didn’t freeze at that time, but I just tried it and it did.

I don’t want to turn on the “Use previous versions of Microsoft IME” option because I don’t like the previous versions of Micorosoft IME.

Is there anything else I can do?

Audacity 3.0.4
Windows 10 version 21H1 (build 19043.1165)

Oh dear, that’s unfortunate.

(I’ve re-opened this topic so that the full discussion can be seen)

Looking at Microsoft’s Windows 10, version 21H1 page is still indicating that at least one issue with IME is known to exist, and are recommending: “Revert to a previous version of an IME”.

I don’t have any better suggestions.