Freeze OS not work button reboot

I use audacity and when i open any audio file (or when import in mp3) then my system freeze, not working button reboot not working keyboard keys, nothing worked, but my system is rebooting shutdown 5 second and start up. hdd start stop bad
sorry i’m not good speak english

I cannot reproduce this problem so we will need to narrow it down step by step.

Which Linux distribution are you using?
Which version of Audacity are you using (look in the “Help menu > About Audacity”).
How did you install Audacity?

Are you able to record with arecord
For example, if you enter this in a terminal window you should get a 20 second mono recording, 16 bit 44100 Hz sample rate:

arecord -f S16_LE -r 44100 -d 20 test.wav

i’m using debian wheezy distro
audacity 2.0.1
i’m install in .deb packages
i’m not view log error, because i’m not know where he

That’s useful - I’m using Debian Squeeze :smiley:

Where did you get the .deb package?
Have you tried uninstalling that version and installing Audacity from the main Debian repository with a package manager (such as Synaptic or Apt)?

Does the suggested arecord command work?

Do you have ALSA and PulseAudio installed?

Yes i’m install from synaptic
yes i’m installing alsa and pulseaudio
I don’t know what arecord

question, whether real not freeze, not bug, stable version (not below 2.Х.Х)

Audacity 2.0.1 from the Debian repository should work fine (I’ve tested it myself on Squeeze and it works fine).

“arecord” is normally installed as standard on Desktop installations.
To use the arecord command:

  1. Open a Terminal window (“Applications > Accessories > Terminal” or press F2 and enter gnome-terminal)
  2. In the Terminal window, copy and paste the following command:
arecord -f S16_LE -r 44100 -d 20 test.wav

To paste into the Terminal use Ctrl+shift+V

The terminal should then print out:

~$ arecord -f S16_LE -r 44100 -d 20 test.wav

which shows that it is recording, then after about 20 seconds the normal command prompt will appear.

If that runs successfully there will be a file in your home directory called “test.wav” that will be about 1.7 MB which is your recording.

If that does not work there is a problem with your sound set-up and we will need to try and fix that so that Audacity can work.

see so everything has to be

arecord -f S16_LE -r 44100 -d 20 test.wav
Recording WAVE ‘test.wav’ : Signed 16 bit Little Endian, Rate 44100 Hz, Mono
users@users:~$ ARecord-е S16_LE-R 44100-D 20 test.wav

users@users:~$ arecord -f S16_LE -r 44100 -d 20 test.wav
Recording WAVE ‘test.wav’ : Signed 16 bit Little Endian, Rate 44100 Hz, Mono

YES file make 20 sec. format .wav

Maybe a problem because of the file?

Excellent. Does that file play OK?


Does Audacity open OK from the Applications menu?
If it does:

  1. Open Audacity
  2. “Generate menu > Tone” and generate a tone.
  3. “File menu > Export > Audio” and export a WAV file.
  4. Close and restart Audacity.
  5. Import the WAV file that you created in step 3.

Does that work?

i’m record music file audacity error freeze os, sound freeze, cursor freeze, ctrl+alt+f1 to work, num lock not work, i’m view log messages but it’s not problem audacity it’s problem kernel and only for 64bit system, turns out that all 64-bit system error freeze not worked nothin.
BIOS-e820: 0000000000000000 - 000000000009d800.
but other audio editor not error freeze.

Oh dear, I don’t think that we can do anything about that.
If this is specific to one particular kernel version, are you able to upgrade or downgrade the kernel to a newer or older version?

i’m update audacity 2.0.2, i’m view of next error
i’m next use button alt+sysrq b (reboot) or alt+sysrq f (out-of-memory kill)
but I think it will not work, and my computer explosion for shutdown and start up
try out a new version

still works normal version 2.0.2 not freeze OS , not format damage, and in my opinion version 2.0.2 high quality sounds, but I’ll watch again if audacity freeze os i’m report.
may be 100 times better test than 1 suffer.
maybe some components of the system in freeze os, with updates can no longer freezing

if you debian stable version support minimum 10 years so it’s big stable and not non-stop update packages and version .

Yes Debian Squeeze is extremely reliable - I have to do very stupid things to make it crash :smiley:

Men Audacity it’s Crushed Files for Freezing OS
shorter words i’m search for next editor, but audacity in the best, I use it often, spoiled
but there is a better editor than

but audacity good work for 3-4 times resets computer button alt+sysrq+b
if you using other commands button OS Freezing.
not Kernel panic not errors


I get the same problem. After doing a couple of random things in Audacity, the system hangs. Very frustrating because inspiration just struck and I can’t make music! Arg. Might be a Debian problem, because I’ve had rare hangs over the last 6 moths after going years without them, but I have not used Audacity in a few months and just now my system has hung within about a minute’s usage of Audacity.

$ uname -a
Linux foobar 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux

packages from
deb testing main contrib non-free

$ apt-cache show audacity
Package: audacity
Version: 2.0.3-1

Nothing I could see that’s relevant in;dist=testing

I’m going to try since Debian’s audacity worked for me in October last year (Not sure if that’s the version I was using though)

Great, compilation failure in an FFMpeg header… maybe newer GCCs don’t like their dodgy stuff. Will hunt for an old Debian binary…

old versions, from the stable release

$ apt-get remove audacity audacity-data
$ dpkg -i audacity_2.0.1-1_amd64.deb audacity-data_2.0.1-1_all.deb

Similar looking messages at startup to before…

ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dmix.c:961:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 4541
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 4541
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 4541
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 4541
Expression ‘*idev = open( idevName, flags )’ failed in ‘src/hostapi/oss/pa_unix_oss.c’, line: 811
Expression ‘OpenDevices( idevName, odevName, &idev, &odev )’ failed in ‘src/hostapi/oss/pa_unix_oss.c’, line: 857
Expression ‘PaOssStream_Initialize( stream, inputParameters, outputParameters, streamCallback, userData, streamFlags, ossHostApi )’ failed in ‘src/hostapi/oss/pa_unix_oss.c’, line: 1234

However, I’ve opened a project, moved some audio around, generated some click tracks, run a plugin on some audio, moved more audio around, and no crash yet.