Format option missing

Hmm, not so “fantastic news”. The tracks created and edited in 3.4.1 are “mono” in 3.3.3 - one ear only! I’m hoping I can export them from 3.4.1 and import them into 3.3.3! :crossed_fingers:

Update: I couldn’t export tracks from 3.4.1 because there were no Export Audio → Format options. I looked for Preference options but couldn’t find anything. I also browsed the Help Forum in case I’d missed something. In the end, I reinstalled 3.4.1. The Format options reappeared as did the ability to import .wav files. So I’m back editing my latest episode in 3.4.1 because the stereo-mono is working fine, and I want to release the episode without the palaver for exporting individual tracks as .wav files and reimporting them into 3.3.3. AND I have faith that the problems with be resolved by the Audacity team!

What do you mean by that? Does the new export window not look like this to you?

No, it did not look like that: there were no options listed under Format. However, as per my post Update, after I reinstalled 3.4.1, they appeared, and I was able to edit and export my latest podcast episode.

I can only assume reinstalling 3.3.3 earlier to get around problems with the 3.4.1 update somehow screwed up the Export Audio Format (even though I installed the versions in different directories).

Again, as per my Update, I have faith that these glitches will be resolved, and I’ll be able to edit my new and old podcast episodes in a future release of Audacity.

Rgds, Robert

Can you send a screenshot how it looks like for you?

When I go to Export Audio, I get the dialogue box but the drop down menus for Format and Sample Rate are blank. I also am no longer prompted to identify whether I want to export an MP3, Wav etc. This just started with 3.4.1. Please help, I need to send a file for mastering.

TL;DR: Audacity did not install correctly, and the modules folder is not included in the same folder as the Audacity.exe. To fix it, reinstall it.

One major part of recent changes (Audacity 3.1 onward) is plucking Audacity apart from one huge pile of spaghetti code into smaller, self-contained libraries (.dll files on Windows). With Audacity 3.4, the exporter got turned into various libraries and modules. In fact, most of the modules folder is responsible for handling different file types:


So, to fix this issue, you need to ensure that all files from the installation/ZIP file stay intact and together, and that they come from the same version.

1 Like


Thanks for the help. I did a re-install this AM and it didn’t work. Just tried again and It worked, I’m back in business/music. Thanks for your help!

Sorry for the delay in responding, but as per my Update, after I re-installed 3.4.1, the Export Audio Format options appeared (the dropdown list was empty before), allowing me to export my podcast tracks to .WAV and .MP3 files. Interestingly, I could also Import .WAV files (I use these for sound effects), which I hadn’t been able to do before re-installing 3.4.1.

So for now, I’ll keep working with 3.4.1 on current and new podcast episodes, and use 3.3.3 (installed in a separate directory) if I need to update older episodes. And I’ll wait for 3.4.2 or whatever that I’m sure will address the backwards compatibility problem.

Thanks, Robert

This topic was automatically closed after 29 days. New replies are no longer allowed.