Flatline Recording Help!!!

Hi there. I use Audacity to record my mixes using my pioneer djm 900 nexus mixer which is up to date. My macbook pro is running the latest version of OS X. I recently cleaned my computer and from that day i’m unable to record using audacity. Previously i was able to almost ‘plug & play’ with my mixer using a usb into the computer and i was able to get signal. I have all the setting set up the same way. core audio then both input & outputs as the djm 900 nexus. any help would be much appreciate as i like to put mixes on sound cloud regularly!

Cheers Cameron

What do you mean by “cleaned”?

Are you using the latest Audacity (2.1.0)?

– Bill

Just to cover the obvious first. Connect any USB audio systems and services first, then start Audacity.


My mac was running slow. So i put all my files i needed onto my external hard drive & wiped my mac. Audacity hasn’t recorded since :frowning:

Does the DJM 900 require custom USB drivers?
Are you using Audacity 2.1.0? Are you running OS X Yosemite?
– Bill

Yes, csmith1997 should reinstall the Mac firmware update from http://www.pioneer.eu/uk/support/software/DJM-900NXS/page.html if they have not already done so.


i’m running OS X yosmite 10.10.3 & i reinstalled the pioneer firmware and support drivers which are also up to date. I’m running audacity 2.1.0. tried to record again still showing a flatline recording.

If the Mac sees the DJM 900 in System Preferences > Sound, use Transport > Rescan Audio Devices in Audacity then choose the USB Codec for DJM 900 in the second “Recording Device” box of Device Toolbar.

Make sure you are sending audio from the DJM 900 to the computer at a loud enough volume.


Hi there,

I have already done the steps you asked me to do there which i had already done before and it failed! Im getting a good signal into the input channel on the sound in system preferences. However audacity isn’t picking up the signal.

I chose core audio-djm 900 nexus- stereo- djm900nexus

Try selecting the device in /Applications/Utilities/Audio MIDI Setup then on the “Input” tab, set the device to the same sample rate that you have bottom left of Audacity and set the channels to the same number of recording channels you have set in Audacity Device Toolbar.

If the Audacity recording slider in Mixer Toolbar is not greyed out, turn that slider up: