Flat Line Audio Imports and Recording Vanishes[SOLVED]

Hi everyone. My name is Jesse and I’m new to this board. I’ve been using Audacity for many years and have had no issues until today. I have NO idea what happened and tried to uninstall and re-install everything associated with Audacity before coming to the forum for help. I’m at a total loss here…

When I try to import my band’s .mp3 audio tracks, they show up as flat lined with no playable audio on the track.

To make thing’s stranger - when I try to record test vocals as a new track without music, they show up as I sing, but after a few seconds, they dissapear from the track and the track flat line’s just like the imported .mp3 tracks and then there is nothing to play back!

I can’t find anything online about this and like I said, I even tried to uninstall and re-install Audacity, hoping that would take care of the issue, but it did not. Same thing happened.

The ONLY thing that has been done differently recently was that I downloaded and installed the LAME file for exporting files as .mp3’s. I’m wondering if that could be the culprit in all of this.

Any help is greatly appreciated!

Thanks a lot!


Do they play correctly in your usual media player program?

Steve - yes. They play just fine. I’m very baffled at this. I just tried uninstalling the LAME program, uninstalling Audacity and then re-installing Audacity without the LAME program and I’m still getting the same issues. This truly came about out of nowhere.


How much free space is there on your C: drive?

Open Audacity and go to:
Edit > Preferences > Directories
What does it say for the “Temporary files directory Location”?

Is “Audio Cache - Play and/or record using RAM” selected? (it should not be selected).

Free Space: 286 GB

Temp Files Location: audacity_temp

Audio Cache Using RAM Selected? - No

What confuses me even more is I just used Audacity two days ago and imported one of the very same .mp3’s that I have tried to use today and layed down a vocal track then with no problems. Today - I can’t get any of the .mp3’s to import or any vocal tracks to record without vanishing a few seconds later.

Which version of Windows?

Hopefully you’ll be able to follow these instructions but if you have trouble please ask:

  • Use the information here to find the audacity.cfg file: http://manual.audacityteam.org/man/Preferences#stored
  • Please make a copy of that file and change the file extension to “.txt” (this will serve as a backup copy and may help us to determine the cause of the problem).
  • Follow the instructions on that page to reset the Audacity preferences, then try opening an MP3 file.
  • If that fixes the problem, please upload the renamed backup copy of the file to the forum with your reply (use the “Upload attachment” option below the message composing box).

If the text box at Edit > Preferences: Directories actually says


with nothing before the “”, that path is the cause of the issue. That path will be whatever Windows sees as the “working directory” (which will usually be the folder Audacity is in, but not necessarily). Audacity 1.3 and 2.0 cannot write temporary data to any folder where the path just starts with “” as far as I can see; I can repeat your issue on Windows 7 x64 with recordings or file import. Audacity 1.2 does not have a problem with this and will write to a temporary directory starting with just “”.

So although resetting audacity.cfg will solve the issue (because it will set the Audacity temporary directory to the full path of your user temp directory), all you should actually need to do is open the Directories Preferences, click “Choose…” then select a folder that you see in the window. This will make the correct “absolute” (written out) path to the directory and should then work wherever the location is.

If this is the problem, have you just updated to Audacity 2.0.0 from 1.2.6, and was the 1.2.6 temporary directory set to “audacity_temp”?


Gale - that did it! Thank you so much!!! :smiley: :smiley: :smiley: :smiley: :smiley: